runerror after installing new version 1.6.0


Downloaded the new 1.6.0 version and installed it on my machine (after removing the 1.5.4 version). When running my project I get the following error:

ImportError: DLL load failed: De toepassing kan niet worden gestart omdat de configuratie van de toepassing onjuist is. Het opnieuw installeren van de toepassing kan dit probleem oplossen.

Note that the long description is in Dutch (since I’m running a Dutch Windows XP Professional version). Roughly translated it says that it cannot start the process due to a configuration error and then the advise is given to reinstall the application.

The project I run did work fine yesterday on the same machine with version 1.5.4. Any ideas?

// the dump
DirectStart: Starting the game.
Traceback (most recent call last):
File “E:_Development\BeeGame\src\”, line 10, in
import direct.directbase.DirectStart
File “E:_Panda3D\direct\directbase\”, line 3, in
from direct.showbase import ShowBase
File “E:_Panda3D\direct\showbase\”, line 10, in
from pandac.PandaModules import *
File “pandac\”, line 2, in
File “pandac\”, line 2, in
File “pandac\”, line 73, in Dtool_PreloadDLL
ImportError: DLL load failed: De toepassing kan niet worden gestart omdat de configuratie van de toepassing onjuist is. Het opnieuw installeren van de toepassing kan dit probleem oplossen.

Can you try running the ‘pview’ tool and see if that runs properly?

Running PVIEW.EXE throws an exception (0xc0150002). I get the impression I’m missing a critical MS-dll or so. Does 1.6.0 requires the Visual C++ 2008 redistributable?

Yeah, try installing that.

It could also be a conflict with an older version of Panda also installed on your machine. Try uninstalling any older versions just to see if that helps.


The old version 1.5.4 was removed using the installer first so I guess that rules out a conflict with an older version.

When I compare the bin folders of 1.6.0 and 1.5.4 the biggest difference is the VS-2008 runtimes that 1.6.0 uses and 1.5.4 doesn’t use. I guess to properly install it, administrator rights are needed, however the installer doesn’t seem to complain about this and the machine I had strong security rules in place.

I also noticed a difference in the manifest file, but I guess that has to do with proper installation of the VC-2008 runtimes.

I’ll try it this weekend on another machine using admin rights.

Yes, 1.5.4 still used 2005 while 1.6.0 now uses 2008.

I have installed version 1.6.0 and have received the same error as a topic starter. I tried to instal ms vc ++ 2008 redist, but it did not operate. I have uninstalled 1.6.0 and have installed 1.5.4. This version works splendid.

What can be a reason?

Installed 1.6.0 on a machine having admin rights. Works fine here. The machine I had the problem on was a laptop running with restricted user rights.

I recently had another program that required the VC++ 2008 runtimes installed and it also gave me an error on the machine. My guess it is related.

mmm… i have admin rights on the machine, and of course, i has installed panda with admin rights…

I have just installed a panda on another computer and there all has works. It seems that the problem arises only on the laptops

I’ve been checking the microsoft specs on the VC++ redistribution. Seems that alle the required files are there, so this cannot be the problem. However, I did found many differences in the manifest files of version 1.5.4 and 1.6.0.

My guess now is that somehow the behaviour of the manifest parsing is different on XP SP2 (the laptop where it failes to run) and XP SP3 (the desktop that runs OK).

Run some additional tests on various other systems. On a deskopt XP SP2 I get the same error. On Windows Server 2003 no error. So my conclusion here is that it is a dependency problem. The VS2008 runtimes require additional runtimes not available in older windows installation and with restricted installation rights these will not be installed.

Downloaded the new installer 1.6.1. Run PVIEW.EXE and it gave the same error. Then downloaded “dependency walker” and run it against PVIEW.EXE. It reported errors.

The first was a missing MSJAVA.DLL. That is easy fixed by adding the dll to the panda bin folder.

The second error is:
“The side-by-side configuration information for …\bin\LIBPANDA.DLL contains errors”, followed by the error code 14001 and the advide to reinstall the application.

I checked the internet on this and there are a lot of articles there about troubleshooting a VS2005 C++ application redistribution. I can only conclude that the xcopy deployment on windows is not working properly.

I’m seeing this problem too on a brand-spanking-new HP desktop that came with XP SP2. It can’t load libpanda.dll in 1.6.1, but 1.5.4 works fine.

It’s failing on pandac\, line 73, when it tries to load libpanda.dll

I tried Windows Update, and I tried the VC++ redistributable. No luck.

Any other ideas?

I figured it out!

I installed Microsoft .NET Framework 3.5 Service Pack 1.

The rest of you who were having this problem on certain computers should try this and report back.

Tested both the 1.5.4 and 1.6.1 on a private desktop with WinXp, SP3. Both run fine. No sign of .Net 3.5 on this machine. So whatever it is, it isn’t the .Net framework. Though it is possible that installing .Net 3.5 fixes the manifest error reported by Dependency Walker.

I dit notice a WinSxS folder containing a lot of manifest files, including many VC++ files. My guess is that on this machine, a different dependency checker is already installed. Probably got it through the autoupdate from Microsoft. So the issue Dependency Walker reports on my laptop is no longer on this machine around.

If anyone else experiences problems like this, try to pinpoint the exact problem and check first with the Dependency Walker tool what it reports before installing .Net 3.5 or anything else to fix the issue.

Tested it again on a desktop with XP, SP2 and no .Net 3.0 and .Net 3.5 framework.

No error on 1.5.4. Got the error on 1.6.1. Dependency Walker reports a side-by-side configuration read error on de libpanda.dll.

Installed .Net 3.5 fixes the problem and now Dependency Walker no longer reports the side-by-side configuration error on libpanda.dll.

However the test yesterday shows that .Net 3.5 isn’t needed, so my conclusion so far is that the libpanda.dll somehow is build differently than the other dll’s. Is it possible it is build for Vista only? Just an idea.

Hmm. Are you able to find out what exactly is wrong with libpanda.dll?

Can someone check if the problem still occurs with 1.6.2? It was built with .NET framework uninstalled, I believe.

Same problem with 1.6.2
Used a fresh install of xp sp3, import error untill i installed .net 3.5