How do you make an RGB File? We are having a problem getting the colors from our blinder to panda. When we put the thing on panda it’s a pure white/gray, and we are having problem getting the texture colors. What do we do?

I’m not quite sure I understand enough about your problem to give you a complete answer.

You want to write RGB files? You mean, image files in the SGI RGB format (which typically have an .rgb extension)? There are several image tools that can write this file format. But maybe you should use some other file format instead that is a little more common, such as TIFF, PNG, JPG, or BMP; Panda can load images from these file formats equally well.

If the image file you generate has colors, then these colors should normally be visible on any object you apply them to. If you are not seeing colors, try viewing the image file with some other image file viewer, like IrfanView, or Gimp, or even IE (if it is a standard format like PNG, JPG, or BMP).

You can also view the image file in panda using pview. Just “pview imageFile.png”, then press the “c” key to center the image.


Do you happen to know the way to make a PNG, JPG, BMP, or Tiff on blinder? Right now we have to use a .X

Blinder? Do you mean Blender?

Ah, I think the light is dawning. You are using Blender to create a model, and you are assigning colors directly to the model, such as vertex color or polygon color. And for some reason that color is not getting converted into Panda properly.

OK, you don’t want to create an RGB file, or any other image file format. Vertex/polygon color is not related to texturing.

This sounds like an issue with the Blender-to-X converter, though. Examine the .x file that you create. Does it contain references to things like “ColorRGBA” or “ColorRGB”? Or maybe it has entries like “Material”?

If it has only “Material” entries, then you might need to enable lighting in order to view your color in Panda. Try pressing the “l” key in pview.

If it does not have either kind of entry, then the Blender-to-X converter you are using does not properly convert vertex or polygon color, and you will need to find some other converter, or use some different way of applying color to your models. (For instance, you could paint a texture. This would involve creating a PNG or BMP file and applying it to the model in Blender. I don’t know enough about Blender to tell you how to do this, but I know it can be done.)


[color=green]Okay thanks. We’ve added light to it, but we haven’t tried to use the model that has color on it yet. ((We have on with color, and one without. For testing purposes.)) Thanks for your continued help.