RenderPipeline error on AMD


#1

I’m using an AMD Radeon R9 Fury Nano graphics card and build panda 3d with win10 and vs2015.

Panda3d and RenderPipeline sources are cloned from github.

my build command is:
thirdparty\win-python3.6-x64\python.exe makepanda\makepanda.py --everything --threads 5 --msvc-version=14 --windows-sdk=10 --no-dx9 --no-tinydisplay --no-nvidiacg --no-fmodex --no-ode --no-physx --no-pandaphysics --no-maya6 --no-maya65 --no-maya7 --no-maya8 --no-maya85 --no-maya2008 --no-maya2009 --no-maya2010 --no-maya2011 --no-maya2012 --no-maya2013 --no-maya20135 --no-maya2014 --no-maya2015 --no-maya2016 --no-maya20165 --no-maya2017 --no-max6 --no-max7 --no-max8 --no-max9 --no-max2009 --no-max2010 --no-max2011 --no-max2012 --no-max2013 --no-max2014 --no-deploytools

I changed vc_version=Visual Studio 14 2015 in rpcore/native/config.ini and build RenderPipeline.

All build successed, but almost every sample from RenderPipeline-Samples-master shows:

[!] Panda3D :linmath(warning): Tried to invert singular LMatrix4.

[!!!] Panda3D :display(error): Shader input IESDatasetTex is not present.

this errors do not appear when i use NVIDIA GT 730 card.

Could someone help me with this problem?
Thank you

Sorry for my bad English, I speak Chinese.

Regards!



#2

You should post this on the GitHub issue tracker for RenderPipeline:

github.com/tobspr/RenderPipeline/issues


#3

The PR (https://github.com/tobspr/RenderPipeline/pull/96) may have solved it.