Python3 support: Anaconda


I’m trying to build Panda3D against Anaconda Python3.5. If I run “python makepanda/ --everything --installer” makepanda clearly can’t find my Python:

Version: 1.10.0
Storing dependency cache.
Elapsed Time: 0 sec
Could not locate Python installation at /Library/Frameworks/Python.framework/Versions/3.5

But I have no idea how to tell makepanda where my python actually is. I tried to follow … 31#p105205 but the code has meanwhile changed so that I don’t know how to fix this.

Thanks for any help anyone can offer!

I would suggest you install Panda in your existing Python 3.5 installation as follows:

python3 -m pip install --extra-index-url panda3d

Thanks! That totally worked.

Just for your information: it works (obviously) using


My ppython is still linked to the Python 2.7 system install. I’m unsure if this is due to pip or due to a prior install that I tried.


Hi guys,

Sorry to come in the middle of the conversation, but the code:

python3 -m pip install --extra-index-url panda3d

did not work for me, so I was wondering if there was something else I could do to install panda3d for python 3 easily. I get the following error:

Downloading/unpacking panda3d
  Could not find any downloads that satisfy the requirement panda3d
Cleaning up...
No distributions at all found for panda3d
Storing debug log for failure in /home/earendil/.pip/pip.log

Could it be related to my distribution? I run mint 17.1.


What version of Python3 is your system using? You can check with

python3 --version

. There should be builds available for Python 3.5 and 3.6.

More specifically, please run this command to get the exact ABI your Python version uses:

python3 -c 'import pip.pep425tags;print(pip.pep425tags.get_abi_tag())'