PView, PZip doesn't work.

Panda3D installed great.
Sample programs work.
I was trying to view a model with pview. It didn’t work.
PZip gave the same error.
It said,

PZip(or)PView: symbol lookup error: /usr/lib/panda3d/libp3dtool.so.1.8: undefined symbol: _Py_NoneStruct

I use XUbuntu, with Precise, btw.

I tried reinstalling and building from source, with no luck.
Same thing each time.
How can I fix it?
Thank you,

Where did you get your Panda3D installation from?

From the Panda3D Download page.

Yes, but which exact build? For which platform/distribution/architecture/os version?

Oh, ok.
Tried with panda3d1.8_1.8.1~precise_i386.deb
Compiled from panda3d-1.8.1.tar.gz
I use Ubuntu precise 12.04LTS with XFCE (XUbuntu)
Linux Version? I don’t think it matters :stuck_out_tongue:

Right, hmm. This seems like an issue with the build, then. Did you compile with Python support? Do you have conflicting Python installation? Do you perhaps have multiple conflicting Panda3D installations?

I only have one Panda3D installed.
It seems I have 2 pythons. Let me try reinstalling with just one (I have 2.7 and 3.2)

Nop, doesn’t work.

It just started working.
How? No Idea :stuck_out_tongue: