PStats port error

Whenever I try to run Pstats I get this error:

I tried turning off my firewall (I use Zone Alarm) in case it was blocking it but I still get the error. It says to try specifying a different port and I did (5186) but it doesn’t fix it. Is there a specific port I should try?

Did you both enable

want-pstats            #t

in the config file, and run the PStats.exe from the bin folder in the Panda3d directory?

It’s when I run PStats.exe from the bin folder I get the error :confused: Apparently I’m meant to have it running first before my program aren’t I?

5185 is the default PStats port, I don’t know of any other program that uses that port. Nor 5186. Either you’ve got a program running that is holding both of these ports open for reasons of its own, or some system configuration is preventing you from opening these ports. Never heard of anyone with this problem before, though.


I’ve had port related errors in other programs in the past, it might be something to do with my security software, I don’t know :confused:

Is there any way to do what PStats does without needing to open ports and stuff?

Ah, it’s working now! I just changed from Zone Alarm Antivirus + Firewall to Microsoft Security Essentials and there’s no problem. Zone Alarm must have been blocking it. Thanks for the help, PStats will be so useful! :smiley: