Pstats (dot) and (komma) bug


I had a problem with pstats on my linux notebook.
When I started pstats I got this warnings:

:prc(warning): Invalid floating-point value for ConfigVariable collect-tcp-interval: 0.2
:prc(warning): Invalid floating-point value for ConfigVariable max-poll-cycle: 0.2

and after I ran my application. I got two other warnings:

Got new connection from
:prc(warning): Invalid floating-point value for ConfigVariable simple-thread-yield-sleep: 0.001
:prc(warning): Invalid floating-point value for ConfigVariable simple-thread-epoch-timeslice: 0.05

Pstats did not show any graphs.

There was a problem with the dot and komma of the prc settings.
To solve this problem you need to set your environment language to english before starting pstats and your application, like this:

$ export LANG=en_US.UTF-8
$ export GDM_LANG=en_US.UTF-8

Then it should run without any warnings.


It doesn’t have to be specifically english; it just needs to be the “C” language, e.g.:

export LC_ALL=C

This sort of thing is an occasional nuisance. Maybe we need to replace every use of atoi() in Panda with a hand-rolled function that doesn’t suffer the same language dependency.


Hm… looks like this is supposed to be already fixed for 1.7.0: … strtod.cxx

Egad. I have no recollection of adding that file, yet cvs claims I did. I was just thinking about what a pain it would be to have to do it today. :slight_smile:


The sad thing is that it appeared not to have fixed the problem.

No doubt due to the fact that ConfigDeclaration calls strtod() instead of pstrtod(). I’ll make this fix.