Problems with libavcodec57

Panda3d seems to be a promising solution after some disappointments with other engines (Ogre, Irrlicht, OpenSceneGraph …) Nevertheless I have a problem with installing Panda3D. My system is Ubuntu 18.04 and I’ve donwnloaded the .deb package. Then I got the message that Panda needs the libavcodec57 package. It isn’t really a probblem to install this lib with Synaptlic but therefore a lot of oher packages have do be removed (about 40 packeges, some of them very important: Gimp, Digikam, Blender, VLC …) Impossible! Can I install Panda3D without the libavcodec? And how? The Python installation with pip works, but my language is C++.

Hi, welcome to Panda3D!

Which .deb package did you download, exactly? You must make sure to match the .deb package matching your architecture and version of Ubuntu; this error is usually the product of such a mismatch.

I’m sure I’ve installed the correct package: Ubuntu 18.04 LTS “Bionic Beaver” (64 bit). Now I tried to install this package on a Mint 9.1 System (based on Ubuntu 18.04) - it works. I think, there is something wrong with the dependencies on my system, probably the installed libavcodec-extra57 is not ok but used by many other packages. It refuses the installation of libavcodec57. Now I know that panda3d is not responsible for the problems. I’ll test it on the new mint system and if it works welll for me, I could update my Ubuntu.


You could also consider compiling Panda from source, which allows you to build with debugging symbols (by setting export CXXFLAGS=-ggdb before the build), which may be useful for you as a C++ developer:

Yes, there are several solutions. I’ve cleaned up my system, and now it works. The problem is that there are 2 packages: libavcodec57 and libavcodec57-extra with additional features. It seems not to be possible to install both an a debian system. Most programs accept both packages, but some apps like clipgrab require the extra package. Yes, and P3D refuses it and insists on libavcode57. Maybe, that was the conflict.

Thank you