Problem with Yabee


#1

Hi,
Are people still using Yabee? i just downloaded panda3d today. i downlaoded yabee from git (https://github.com/09th/YABEE) I have problems exporting the default cube with uv map that i added from blender 2.79b. and unmarked (animation only, separate animation files, all actions as animations) and marked (copy texture files, merge actor, apply modifiers). When I pview it in panda3d, it says error reading cube7.egg
loader(error): couldn’t load file cube7.egg: invalid.
unable to load cube 7.egg
framework (warming): Empty bounding volume for models
vertex shader was successfully cipled to run on hardware
fragment shader was successfully compiled to run on hardware
display:gsg:glgsg(warning):sharder created shader produced the following warning : fragment shader linked, vertex shader linked.

nothing shows, but a grey screen . What should I do? Please help. thanks in advance.

Update…now I can import the cube.egg into panda3d, I found out I was applying texture wrong. but now, i;m trying to import figures and animation and I have two issues:

  1. when i try to export a figure without animation as a .egg file through yabee, same settings as above, panda3d gives me an infinite loop on the console and i can’t read what it is saying, something about error and unknown, but it is going too fast for me to read and wont stop so i have to force the console to close. So, I dont evenwant to try loading animation. What am I doing wrong with Yabee that it is not wanting to work. I mean other than the cube, I have so many other files, that exported as an .egg don’t work, but if i export as an x or a bam file, it works.

  2. when i export animations using bam, I only get the tpose, I can’t get the actual animation. I tried replacing the roaming ralph game with my own animations, and all i get is a moving tpose. Bam, however, has no other settings, other than export.

Please help. thanks in advance.


#2

I don’t use EGGs/YABEE, so hopefully someone else will chime in to answer your EGG question. However, to answer your BAM question: I do not believe the BAM exporter supports animations. You can try using the BAM exporting capabilities of BlenderPanda, which does support animations.


#3

I use YABEE.

I see that issue (2) above has been addressed by someone else, and that your initial problem ha been fixed (do I guess correctly that you simply didn’t have the object selected? If not, what was the issue?). So, let me address issue (1) above:

Are you running the program from the console/terminal? If so, and you’re running under Windows or Linux, I think that you should be able to interrupt the program by pressing Ctrl-C. That might allow you to see what the error is, which might prove very useful in figuring out what the problem might be.

If you’re not running the program from the console/terminal, then pressing Ctrl-C might result in the console closing anyway. In this case, I suggest running it from the console/terminal–that is, open up a console/terminal, direct it to your program’s directory, and run "python ".


#4

Wow thank you so much for your help. I uploaded the BlenderPanda and I tried to export as a bam, but only got an untextured tpose. I think I’ve tried everything. I’m only trying to import animations from iclone via 3dxchange into panda, but it seems the animations and figures, file structure and textures are too complex, but thanks anyways for the help. Ive tried so many other programs to export different versions of fbx, x, dae 3ds, etc and tried to convert them to bam or egg, and it just seems like it was never meant to be. I’ll get over it. Thanks.


#5

Yes, thank you, I’m running from a windows console and ctrl c worked it stopped the console- and it says:

Unknown texture 4_meshes_Merge_Opacity

Error in question.egg at line 172314, column 39:
{ 4_meshes_Merge_Opacity }
^
Unknown texture 4_meshes_Merge_Opacity

Error in question.egg at line 172322, column 39:
{ 4_meshes_Merge_Opacity }
^
Unknown texture 4_meshes_Merge_Opacity

Error in question.egg at line 172330, column 39:
{ 4_meshes_Merge_Opacity }
^
and it goes on and on and on

anyway, since I asked, the question, I’ve been up all hours of the night and I figured out that if i put tbs generation at panda, text processing at bake, and i check merge actor, apply modifications, pview, use custom vertex normals, export pbs, force export vertex colors it works. However, whenever I do that, I try to import animations with .egg and all I get is a textured tpose. The name of my animation is run.egg and so from the folder with the egg file, I run a command line “pview run.egg run.egg” thinking that I can use the animation file for both the actor and animation. Hopefull that’s the right way.

And yeah, I learned, since I jus started using blender 1 week prior, I had to select it by right clicking and pressing select on the figure, that made a big difference. Thank you so much for helping.


#6

Ah, that does indeed help somewhat, I think. It appears that it’s failing to find a texture named “4_meshes_Merge_Opacity”. I presume that you have this texture somewhere–perhaps it’s worth checking that you don’t have it specified via an absolute file-path, rather than a relative one.

I’m not sure of why it works with the settings that you’ve just described–I don’t really use the “bake” setting. Perhaps it’s finding it easier to locate the baked texture.

Regarding the animations, I’m not clear on whether you still have “Separate animation files” unchecked–your initial post indicates that, but your latest post seems to suggest that you’re getting separate animation files.

If it is still unchecked, then I think that you would want to just run “pview .egg”–but I may be mistaken.

If it’s now checked, then I don’t think that pviewing an animation file alone will work; instead, I think that you would instead run
“pview .egg .egg”.

Hmm… If you’re still having trouble after this message, would you be willing to post a simple, small .blend file that exhibits the problem on your end? Perhaps just a cube with a stand-in texture. I recommend that you set the various values for YABEE before you save–I’m not sure of whether they’re stored in the .blend file, but if they are, it might be handy to have them available.


#7

Thanks for responding so quickly. Sorry, if it seems that I’m not really trying to do anything anymore. I’ve been a little hopeless and exhausted lately because I think I tried all the options and all the software possible and i think I need a rest, but anyway, I’ve uploaded to google drive, the fbx file, blend file, egg file with egg settings hopefully saved. and a screen shot. I like to use Daz and used the figure from daz to animate in iclone exported from 3dxchange to get into panda. I do have multiple egg files and bam files, but each animation is separate since they were exported from 3dxchange. I don’t even know what that option is for or how to use it. What does separation animation files mean if i only get to load one animation file in fbx. if i were to load another, it would be a separate figure and i can’t export both together in an egg file, right? I know it is easier to export to unity or unreal, but I wanted to learn python and panda is really good for python. anyway, i haven’t been able to sleep due to trying to export different versions and types and softwares possible. I almost feel bad that you’re wasting your time trying to help me. IThe link is below:

https://drive.google.com/drive/folders/1tA3m1vEvPymMzh5-I5AuaJBjmfnyuLcN?usp=sharing


#8

You’re not wasting my time, as far as I’m concerned. After all, I’m choosing to respond to you.

I’ll confess that I’m not familiar with Daz, iclone, or 3dxchange. ^^;

The “egg” file-format can either store its animations along with the model-file, or in separate egg-files, one per animation, I believe. That’s what “Separate animation files” controls: If it’s left unchecked, you get a single egg-file that contains both the model and whatever animations you’ve exported. If it’s checked, you get one egg file for the model, and in addition, one egg file for each animation.

I’m not sure of why you only get to load one animation–I take it that that’s something to do with fbx importing into Blender? Blender can hold more than one animation/“action”, and YABEE can export multiple animations, I believe.

Turning to the files that you transferred:

Okay, looking at Blender, I see the model, with textures applied, and a single animation (running).

Looking at YABEE, I see that you have “All actions as animations” unchecked, but no animations specified in the box just below that. This means that you’re not telling YABEE to export any animations–and so it presumably doesn’t. It just exports the model itself, in its default T-pose.

The exportation does seem to be somewhat finicky with your model. It seems like sometimes it works, and sometimes it doesn’t–even with the same settings. o_0 If it fails with the settings that I give below, just try repeating the export a few times.

I wonder whether this finickiness might not be due to your making extensive use of shape-keys, if I’m not much mistaken–I don’t know how well YABEE supports those.

Nevertheless, I got it to export with its animation by additionally checking (in YABEE) “All actions as animations” and “Separate animation files”. (This causes it to export all dope-sheet actions as animations, and in separate files, respectively. However, it may cause YABEE to export some superfluous files, for some reason. Feel free to delete the extras–just not the model or animation!)

Additionally, I had “Tex. processing” set to “Simple”, but “Use custom vertex normals”, “Export PBS”, and “Force export vertex colors” unchecked. (I think that I have seen it also work with those all checked, however.)

Oh, and I forget whether this has been mentioned: remember to select both the object, and the armature!


#9

As for the 4_meshes_Merge_Opacity error, I wonder if the .egg loader has trouble with textures whose name start with a number. Try making sure that the texture name has a letter or underscore at the beginning.


#10

It looks like it’s fine on those occasions on which it exports correctly on my end, even with the numeric initial-characters.

Something that I remembered after my post above: I think that Panda3D may be able to import fbx files these days. Unless you’re making changes in Blender, perhaps it would be worth attempting that, if the original poster hasn’t already. (And my apologies if something to that effect has already been mentioned–I may have missed or forgotten it. ^^; )


#11

oh, yes, oh yes, thank you so much. I got it, but I didn’t use those settings you were talking about. those settings produced the same unknown texture error that i was saying above. but anyways, i have to try to calm down, first and take a deep breath before i have a heart attack. wow, I can’t believe it works, yes. It’s because you said
" “All actions as animations” unchecked, but no animations specified in the box just below that. This means that you’re not telling YABEE to export any animations–and so it presumably doesn’t. It just exports the model itself, in its default T-pose."

so that’s what I did , in addition to marking everything else that I was telling you about in the screenshot:
all actions as animations unchecked, but then i pressed the plus button and added the frames from 1 to 40 where my animation was
animation only unchecked
tbs generation at panda
text processing at bake
check
copy texture files
check separate animation files (and the
check merge actor
check apply modifications
check pview
check use custom vertex normals
check export pbs
check force export vertex colors
I don’t know maybe different computers or versions cause different outcomes, like an error message on my side, but an animation on yoru side. But anyway, thank you so much for your help. i wanted to wait until I tried other animations, and I didn’t want to speak too soon, but man, anything is good, even if it is one animation. Now I really can’t sleep even though i’m tired, but how can i sleep now? No but I need to sleep. oh man, thank you so much. Roaming ralph, here I come!


#12

I tried using again, but this time I followed the directions on the manual. I only found textures exported, but no bam animations in the folder I exported to. Thanks again for the suggestion.


#13

Thanks, I couldn’t sleep until I did this game. So, I have it, but it works. I have to find a way to make the animations loop so it looks better. and so he is able to walk on top of things instead of sometimes disappearing into the hill or getting stuck at the edges of the world. I think instead of him walkig forward, i should try to make him walk in place next time.
Thanks.

https://drive.google.com/drive/folders/1tA3m1vEvPymMzh5-I5AuaJBjmfnyuLcN?usp=sharing


#14

It’s my pleasure–I’m glad that you managed to get things working!

Good luck with your next attempt, and I hope that it goes better than this one! :slight_smile:

(And indeed, I recommend having the character “walk in place” when making a walking animation for use with free character movement.)