Problem running tutorials in Mac OS X Mavericks, XQuartz

I am not sure if it is X11 XQuartz or Mac OS X Mavericks, but the python tutorial examples don’t accept keyboard or mouse events.

In Mac OS X Mountain Lion it was working fine, but now the examples are not interactive anymore. It is not possible to move the scenario, or to accept keys.

I have tried with Panda 1.8.1 and 1.7.2 with no luck.

Any help would be appreciated, thanks!

Can you try this experimental build?

Same problem here. Did you try the experimental build elneto?

With the experimental build running the asteroids tutorial I get:

dgp:/Developer/Examples/Panda3D/Asteroids $ ppython
DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
Traceback (most recent call last):
File “”, line 13, in
import direct.directbase.DirectStart
File “/Developer/Panda3D/direct/directbase/”, line 4, in
base = ShowBase.ShowBase()
File “/Developer/Panda3D/direct/showbase/”, line 244, in init
self.openDefaultWindow(startDirect = False, props=props)
File “/Developer/Panda3D/direct/showbase/”, line 887, in openDefaultWindow
self.openMainWindow(*args, **kw)
File “/Developer/Panda3D/direct/showbase/”, line 923, in openMainWindow
self.openWindow(*args, **kw)
File “/Developer/Panda3D/direct/showbase/”, line 637, in openWindow
win = func()
File “/Developer/Panda3D/direct/showbase/”, line 623, in
callbackWindowDict = callbackWindowDict)
File “/Developer/Panda3D/direct/showbase/”, line 689, in _doOpenWindow
File “/Developer/Panda3D/direct/showbase/”, line 527, in makeDefaultPipe
“No graphics pipe is available!\n”
File “/Developer/Panda3D/direct/directnotify/”, line 136, in error
raise exception(errorString)
StandardError: No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.
:TaskManager: TaskManager.destroy()

With the 1.8.1 build, it ran for me but with no input as described by others here.

Set the PANDA_PRC_DIR environment variable to /Developer/Panda3D/etc as a workaround.

Also tried the experimental build with the environmental variable set to /Developer/Panda3D/ and /Developer/Panda3D/etc/.

Still no luck.

Hmm, sorry, I think I made a mistake with the build that makes this variable called PRC_DIR. Try setting PRC_DIR to /Developer/Panda3D/etc/ .

Thanks rdb. That worked.

I’m new to Panda3D and encountered the same problem. Pardon me if this sounds like a stupid question - how exactly do I reset PRC_DIR?

Huh, the issue has been solved a long time ago, so you must be running into a different issue. Which build of Panda3D did you install? Which Mac version?