Problem exporting animation with Egg Exp / blender [Solved]

I have imported a man and a .bvh file to make the walk.
I have linked (CTRL+P parent bone) with the bone.
I have made a keyframed animation and it’s great under blender.
But when i export with Egg Exporter (0.91 for example), there is no animation that i can select.
So, i link every object to the armature. No change under blender, it’s also good. And under Exporter Egg, i’ve the animation button. So, i export into 2 files, and nothing… i’ve my model, the animation, but my model don’t move !!!
So, i weight paint all object like i can… and under blender, no change in apparence… but the animation after exporter is… not beautiful : there is some point (verticles) that are fixed or something else, there is deformation. Some part of my model are animated, and some other… not really. It’s look bad. Is my Painted not good ?
I’m looking for a solution more… simple. Could you help me ?
Greg, from France.

Edit: i’ve not selected the option “vert. group” in the modifier armature option. If i do that, my model is not correct. Is the reason ? How can i correct this ?

You can download the blend file here :
I don’t understand…

Hi, welcome to panda3d

the chicken exporter does not support parenting of armatures.
This technique is old, deprechated, and it’s highly recommended to not use it anymore.
Please use the “armature modifier” instead.
For details please read the Chicken manual.(the help button in the export menu)
We also have a Video tutorial about how to do basic animation in blender and export them. guess you can skipp the modelling and animating part of it.

Thank you, but i’ve already made this as you can see in my question.
The problem is different. The egg exporter don’t see my parenting of armatures, so it’s not a problem, isn’t it ?

If y only do the armature modifier, i don’t have the same result. My model is deformed instead of having éléments like arms rotating like i want to.

Is it possible to have the same ? The video is very usefull but don’t explain that sort of thing.

Do i have to make multiple armatures to simulate the précedent bones or is there a solution when using armature modifier to have the same result (accessing bones, like arms and not the entire skeleton).

Sorry for my english…

well. unfortunately this is a problem.
you must unparent your armature and mesh. if you dont, the transforms will be completely messed up (thats propably what you see yourself right now).

if your model does not animate the same as with reparenting, you might have to fix your bone-weights. it is possible to have the exactly same result if you dont do something strange.
also note: the chicken exporter does not support envelope-weights. so you should turn them off in the armature-modifier.

you can only use one armature per character. you can use multiple meshes but they all have to use the same armature. accessing individual bones is possible.

[EDIT]: i just had a look at your model. well. it’s… a mess :smiley:
1: all your meshes are parented to the armature. you have to unparent them
2: your armatures are deactivated (vertex-group are off)-> enable vertex-groups in the armature-modifier for all meshes.
3: your bone weights are totaly messed up. the leg meshes are weighted to neck-bones etc. i suggest you re-do them from scratch.

once those things are sorted out (i only did it for one leg) it exports fine.

Thank you, i understand the problem now. I’s clear.
I would like to have another advice.
How can i do to avoid that sort of thing when i paint weight ? (screen copy here : )
it’s because it’s a bit hard not to forget a thing here.

that’s totaly up to you.

i always paint a part. then move the entire armature around and see if there are any spikes, then i paint over the spikes which should be painted.
you can also make a selection in edit mode , switch to weight mode and hit the “mask” button. which will only paint the selected vertices. this way you can freely weightpaint without having to worry about other parts beeing painted by accident.

there are lots of tricks. most of them can be found in numerous blender tutorials.

Thank you a lot. Now, i know how to animate a object.
It’s a pity that we can’t export animations which are based on parent bone, because it’s more easy when we have a multipart object. But it’s now for me an accepted fact.
I continue my development, thanks again.


i have another problem with the export to egg

i have exactly obeyed the video
and i’ve done it againd and again, but the pview says me, that there is no animation?!?

i have vista 32b and i had another problem with the exporter, he could not find python without the “pythonpath”

i dont know wheter this is another problem because the eggexporter could not find python without this pythonpath

mfg Beowulf1988

looks like you have to fix your environment variables so blender finds your python installation. since i’m not using windows i cant really tell you how to do it. but there should be several topics here on the forum discussing how to correctly do that on windows. searching the forum for “chicken installation” may pop up some results.

i have fixed the variables und blender find python, the exporter too, so i can export objects, but no animations

maybe there is something with the amatures?
maybe there is another way to create animations as the video shows?

I had the same problem because the modifier “armature” was applied or i didn’t use it. Have you the armature modifier visible under blender ?

hmm…it sounds good ^^

but sorry for this silly question…how do you mean visible…how can i do the modifier visible?!?

No it’s my poor english
Click on your object in “Object Mode”
Go to menu “editing”
Modifier is right
You must have the Armature modifier active (not applied) with “vertex group” underlight et not enveloppes
If you don’t have that, you’ll never see “add animation” under Egg Exporter

oh i’m sure my english is not better than yours ^^

I did it but still theres no animation

I tried it now on another pc with linux where are no problems with eggexporter and python but there is no animation too…

hmm but thx for your help…

I’ll try it again and again ^^

if you can provide the.blend file we can have a look at what’s going wrong.

oh sry…a good idea … blend.html

The file has no problem - i’ve exported the animation without any modif
The method is good, so it’s your blender/Egg exporter config.

hmm…okay and thx for testing…

which eggexp version do you use? my is R91

Me too
I’ve an idea, you can test with :
It’s a file test from the creator of chicken Egg Exporter.
You’ll have a blend file and you can export with anim
Tell us

hmmm…its the same…=(

and with the active buttons in the chickeexporter (egg2bam and egg2optchar) i get 2 warnings and 1 error

but i think this buttons are not import?