Problem: Blender export with no vertex normals

I have exported some models from Blender. I tried both methods and they work fine, but there are no vertex normals, so my objects don’t look smooth in Panda3D.

Is there any Blender user, who knows how to fix this?
(I use Blender V2.37 if that is important)
Thanks in advance :wink:.

Are you sure the edgy appearance is due to missing vertex normals? Couldn’t it just be a general lack of shading?

There are a lot of ways to export from blender, and many are only partially functional. I believe some guy wrote a blender export script, and it’s not finished. It is possible to export from blender, you just have to know which exporters to avoid and which ones to use. As I understand it, the currently preferred method is to export to X file format (which panda can read directly). As I understand it, the X file exporter has a version number, and the most recent version is not included with blender - you have to download it. I’m afraid I cannot remember the minimum version number.

If you are using the X exporter, and there are no normals in the X file, then there’s not much help I can give. If there aren’t normals, and you can’t figure out how to get the X exporter to work correctly, then panda contains a workaround - you can ask panda to generate normals for you. Before I tell you how to enable the workaround, let’s see if you can get it working the right way first.

If there are normals, but you’re still seeing a flat model, then it means that you haven’t configured lights.

Oh, and could I beg one of you guys who uses blender to update that page of the manual?

It’s still on my todo-list, Josh - sorry for letting you wait, but I currently have a thousand things to do, at work as well as at home.

OK, i used the new DirectX8 exporter and now it works.