Prebuild precise package ruins xorg on 12.04.2

The prebuild package available in (Ubuntu precise) requires the removal of a lots of xorg pakages.
This is the log:

Requires the REMOVAL of the following packages:
libgl1-mesa-dri-lts-quantal libgl1-mesa-glx-lts-quantal libglapi-mesa-lts-quantal libxatracker1-lts-quantal ubuntu-desktop x11-xserver-utils-lts-quantal xorg xserver-common-lts-quantal xserver-xorg-core-lts-quantal xserver-xorg-input-all-lts-quantal xserver-xorg-input-evdev-lts-quantal xserver-xorg-input-mouse-lts-quantal xserver-xorg-input-synaptics-lts-quantal xserver-xorg-input-vmmouse-lts-quantal xserver-xorg-input-wacom-lts-quantal xserver-xorg-lts-quantal xserver-xorg-video-all-lts-quantal xserver-xorg-video-ati-lts-quantal xserver-xorg-video-cirrus-lts-quantal xserver-xorg-video-fbdev-lts-quantal xserver-xorg-video-intel-lts-quantal xserver-xorg-video-mach64-lts-quantal xserver-xorg-video-mga-lts-quantal xserver-xorg-video-modesetting-lts-quantal xserver-xorg-video-neomagic-lts-quantal xserver-xorg-video-nouveau-lts-quantal xserver-xorg-video-openchrome-lts-quantal xserver-xorg-video-r128-lts-quantal xserver-xorg-video-radeon-lts-quantal xserver-xorg-video-s3-lts-quantal xserver-xorg-video-savage-lts-quantal xserver-xorg-video-siliconmotion-lts-quantal xserver-xorg-video-sis-lts-quantal xserver-xorg-video-sisusb-lts-quantal xserver-xorg-video-tdfx-lts-quantal xserver-xorg-video-trident-lts-quantal xserver-xorg-video-vesa-lts-quantal xserver-xorg-video-vmware-lts-quantal

if I press Y, panda3d is installed and, after a reboot, xorg is broken.
Is there a bug in the package?


Are you sure that your system is actually a working copy of precise? I mean, it looks like you have a lot of packages with the suffix -quantal instealled.

Yes i am sure.

lsb_release -a output is:
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

quantal packages are backported for what is called LTS Hardware Enablement Stack. 12.04.2 use some quantal packages, mainly kernel and xorg, to provide support for newer hardware, you get this only installing 12.04.2 from scratch. If you update from 12.04.1 old kernel + xorg are kept.

Is it possible that this backport is the source of the problem?

Yes, that seems to be the problem. Maybe the build for quantal works?

No, quantal package do not work.

If i try to install with gdebi the output is:
This package is uninstallable
Dependency is not satisfiable: libavcodec53 (>= 6:0.8.3-1~)|libavcodec-extra-53 (>= 6:0.8.5)

Can you find out which package that Panda3D depends on that breaks the LTS backports? Perhaps with “sudo aptitude why-not”?

This is happening to me too. And, yes, it only happens when run on a 12.04-2 fresh install (that is, you start with 12.04-2, not upgrade from 12.04 or 12.04-1).

The last time I fixed it by just re-installing xserver-xorg after rebooting (from console, of course, since your gui is gone) and then reboot again. YMMV. And I just noticed that it’ll un-install ubuntu-desktop, but I don’t remember having to re-install that. Hmmm…

Here is the output of what dependencies it’s missing…

Selecting previously unselected package panda3d1.8.
(Reading database ... 345762 files and directories currently installed.)
Unpacking panda3d1.8 (from .../panda3d1.8_1.8.1~precise_amd64.deb) ...
dpkg: dependency problems prevent configuration of panda3d1.8:
 panda3d1.8 depends on libboost-python1.46.1 (>= 1.46.1-1); however:
  Package libboost-python1.46.1 is not installed.
 panda3d1.8 depends on libegl1-mesa (>= 7.8.1) | libegl1-x11; however:
  Package libegl1-mesa is not installed.
  Package libegl1-x11 is not installed.
 panda3d1.8 depends on libgles1-mesa (>= 7.8.1) | libgles1; however:
  Package libgles1-mesa is not installed.
  Package libgles1 is not installed.
 panda3d1.8 depends on libgles2-mesa (>= 7.8.1) | libgles2; however:
  Package libgles2-mesa is not installed.
  Package libgles2 is not installed.
 panda3d1.8 depends on libopencv-highgui2.3; however:
  Package libopencv-highgui2.3 is not installed.
 panda3d1.8 depends on libosmesa6 (>= 6.5.2-1); however:
  Package libosmesa6 is not installed.
 panda3d1.8 depends on python-pmw; however:
  Package python-pmw is not installed.
 panda3d1.8 depends on nvidia-cg-toolkit; however:
  Package nvidia-cg-toolkit is not installed.
dpkg: error processing panda3d1.8 (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for shared-mime-info ...
Errors were encountered while processing:

If there is interest, I can make a build for 12.04.2 and host it with the other builds I provide. Then the dependency problems should be gone.

JörnS, that’s very kind of you to offer.

It’s not a pressing matter for me, personally, but I defer to others as to how important this is as a bug to fix.

I don’t really understand what’s going on here. These packages are certainly in the Ubuntu repositories. What does it tell you if you try to explicitly install said packages, such as “sudo apt-get install nvidia-cg-toolkit”?

Ah, but Panda does perhaps use some packages from the “multiverse” or “universe” components of the Ubuntu distributions. Perhaps you simply need to enable these in the package manager settings to allow these packages to be found?

Failing that, if multiple people are having the same problem, it might be that the build scripts are somehow building for the wrong distribution. I’d take a look at the build server to see what’s going on, but well, it’s down.

Well I have some time and look into it. Fresh VM with Ubuntu 12.04.2, of course with hardware enablement stack. For your information: even the virtualbox-guest-dkms doesn’t work.

panda3d1.8_1.8.1~precise_amd64.deb breaks X, because it depends on the X server from Precise but finds the Quantal one. panda3d1.8_1.8.1~quantal_amd64.deb has unfulfilled dependencies / wrong versions. The build scripts are fine, Reinier. At least for me, the problems are logical. I’ll build Panda for 12.04.2 and the problems should be gone.

Build for 12.04.2 is online! Look at my thread Panda3D downloads for several distros

I had this problem and had to reformat twice because I didn’t know why it was happening (and wanted to be sure it was panda). Thanks a bunch JörnS, your builds worked. I literally made an account to thank you.

Really glad to hear that, sprkh. I think the Xorg+kernel backports from Saucy are already in proposed, so a preview build for the stack from the upcoming 12.04.4 will roll out soon.