ppython Not Recognized

‘ppython’ is not recognized as an internal or external command,
operable program or batch file.
is the same message I keep getting the same error message in my Command Prompt when I try to run Panda3D. I got it to work the first few times I loaded it. Then I noticed it was taking up about 88% of my CPU Usage, so I closed it down immediately to prevent lag. I tried to load it back up again, to see if this would happen again, but instead I got the error message above…

I know that ppython was recognized before, but now it isn’t. I did absolutely nothing except close Panda3D, close the command prompt, reopen the command prompt, go to the correct location of my .py file, and then typed “ppython PandaGrassyCamPanda.py” and got the error message.

Did I install it wrong or something?


It sounds like the C:\Panda3D-1.0.5\bin directory (or wherever you installed it) isn’t on your PATH variable any more. Don’t know how it got lost, but you can put it back (in a particular command shell) with a command like this:

path c:\panda3d-1.0.5\bin;%PATH%


Thanks! It works now :smiley: