PPAPI plugin


#1

Hi
Since google chrome decided to remove support for NPAPI plugins early in 2015, it would be nice to have new PPAPI plugin.
See my question here: productforums.google.com/forum/ … Kr0ceDsotA
It seems NPAPI plugins already gone in linux.
I’m not a C/C++ developer, but i guess this could help: code.google.com/p/ppapi

Thanks.


#2

Hmm, that’s a shame. It’d be quite a bit of extra effort to port the plug-in to yet another API just for the sake of supporting Chrome.


#3

Yup, Should develop new API.


#4

From what I’ve heard if successful all browsers will switch to en.wikipedia.org/wiki/WebAssembly one day.


#5

Yeah. There is a WebGL port underway, which works well:

I presume WebAssembly will be supported by emscripten, so it shouldn’t be too difficult to support WebAssembly when it is finished.


#6

Well if there’s a WebGL port under development, I personally don’t think there’s a reason to further develop the web runtime which requires a runtime install. I know there are old GPUs which don’t support WebGL but I think there are more important features to spend time on.


#7

I agree. It’s likely that real players/users of a real Panda-based game or web app would much rather just use a browser that supports WebGL instead of going through the plugin installation. In my opinion, WebGL should eventually be used as Panda’s main web-embedding system instead of browser plugins.


#8

That sounds like a nice goal to work towards, if the performance turns out to be good enough for serious applications. :slight_smile: