Please add support for Android armv8l architecture

When I tried compiling panda3d on termux I got this error :
Android architecture must be arm, armv7a, arm64, mips, mips64, x86 or x86_64
Build terminated.

Hi, welcome to the community!

What happens if you pass an --arch flag to makepanda? I am not sure if armv8l is 32-bit or 64-bit? You could try passing --arch arm64 or --arch armv7a.

Hi, thank you for your quick response!

armv8l is 32 bit mode in 64 bit CPU.

passing ‘–arch armv7a’ gives this error

After a bit googling I found this:

Also, I have already installed all the required dependencies but I still get those warnings…

Doesn’t look like you have a lot of thirdparty packages installed on your system, did you install the recommended packages listed in Do you have any compilers on your system? What are they called?

Yes, I installed all the packages listed in I also tried install them again and it shows that they are already the newest version.

I have clang-15.

What are the names of the clang executables? Which prefix do they have?

clang, gcc, clang++ and g++.

So you have no prefixed compiler commands at all?

Sorry I almost forgot about this thread…
After reading some docs about android, termux, compilers and libgdx I was able to create a basic app with a 3d scene, skybox, shaders and gltf model rendered on screen.
So I think the problem was with panda3d…also I found that armv8l is backwards compatible with armv7a because libgdx also doesn’t have any native library for armv8l.