Particle transparency in surface

I have a problem at transparency when use point emiter and sprite renderer:

You can see black region around my texture. In my opinion, one pixel only have alpha value at 0 or 1 :frowning:
And this is my texture:

and ptf file:

Similar issue has been discussed several times try to look on the forum
For example:

In your case, I would advise actually disabling the normal transparency mode and using a ColorBlendAttrib set to MAdd, this should give perfect alpha blending for your situation. (You may need to adjust setColorScale down in order to attenuate the contribution of the colours.)

You may need to disable depth write on the particles as well and put them in the ‘fixed’ bin to control their render order.