Panda3D window does not appear (using PyQt4)

In my PyQt4 application I created a Panda3D window, next to the Qt window: code and screenshot.

My problem is that this code runs fine under Gentoo Linux (using Panda3D-1.5.2), but the Panda3D window doesn’t appear under Microsoft Windows (using Panda3D-1.6.2) on the same computer.

The full output:

The full installation instructions can be found here.

That’s a perfectly normal output. My guess is that Panda thinks it’s creating a window and parenting it normally; perhaps there is some Qt-specific reason that the window remains hidden under Qt/Win.

You could confirm that exists and that shows the parent window ID. You could also run PStats to see if it appears to be spending time rendering.

But so far, I don’t know what the problem could be.



Yep, see, all perfectly normal. As far as Panda knows, it’s created a window and attached it successfully to your Qt parent window.


Another linux user reported that the Panda3D window didn’t appear for him.

Apparently the window appears when using Panda3D-1.5.2, and it doesn’t appear when using Panda3D-1.6.2.

Hmm, interesting. Same behavior on Windows and on Linux? That’s particularly strange, since the window creation code is completely different in both cases.


i am facing the same problem now, have you solved this problem?

No, sorry. I haven’t had a chance to install PyQt4 yet and investigate. If anyone else has the time to look more deeply into it, we’d all certainly appreciate the contribution. :slight_smile:


it works now.

Could you please share your solution?

Anyone had this solved ?

My problem is a bit different. There is no warning on my desktop(winXp) but there is a warning on my laptop(win7) and some gui objects(mostly geometry of gui objects) are also not loaded.

I’m having what appears to be the same problem.

I’m using Panda3D 1.9.3.

Did anyone find the solution to this?