Panda3d build on Android via Termux

Hello everyone,

I tried to install Panda3d on my Phone since 2 days, there are alot of different ways explained on this website or git, I tried all, but the best I could do is to clone pydk from git on Termux… it was also the newest solution out there.
But once cloned what are the next steps? That would be great if i could have an actual and up to date explanation. As I don’t have any PC, to have such an engine to experiment with on android would be awesome. Best thanks!

Have you tried following the instructions here? This is what I did the last time I use Panda3D with Termux, and it work for me. Now, it has been a while, so things may have changed since then. What, if any, issues/errors are you running into with these instructions?

Thank you for your reply, yes that was the first I tried…

Did you cd into the panda3d directory before running python makepanda/makepanda.py?

No I didn’t, thanks for pointing that out… Now it started to build… At least until 49%

That looks like an issue with the Panda3D codebase, and I recommend filing a bug report.

Thank you, I will do that.

The None at that location in the source code needs to be changed to nullptr. I’m checking this in to GitHub.