Panda3d and Aptana Studio as IDE-MacOsX Help

Hi Guys,

I recently started using Aptana Studio (great and free programming IDE for several different languages, based on Eclipse, but much nicer and less system intensive) and noticing it allows extending the program via plugins I decided to give their python’s “pydev” plugin a try with Panda3d.

After installing the plugin, all you gotta do is go to the “window-preferences” menu, and from the interface that loads, select “Pydev - Interpreter Python”. Then set the path to your Python’s executable and it will load all the connected libraries implied, including Panda’s which are not selected by default but you can enable them by marking its check and include them.

After this, you can create a new python project, copy (import) all your python sources and resources into it, and compile and run by simply right clicking your file and selecting “Run as -Python run”. Its a great way to develop fast since Aptana enables a very good outliner that makes reading and modifying code a lot easier.

However, this only works flawlessly in Windows and Linux. You just select the path to your python executable, and everything loads ok, but in MacOsX the Panda3d libraries are not detected by default as in the other OSs. When I point pydev’s interpreter path to: /Library/Frameworks/Python.Framework/Versions/2.5/Resources/ and the executable in it, only python’s libraries get detected but none for Panda3d.

I assumed that panda’s variables that get set with the script in the MacOSx installation, would point any default python info to panda’s. :frowning:

Is there a way to include panda’s libraries by hand in MacOsX for a pydev project?


Aptana’s site:

Not sure if this is relevant but have you seen this thread?

Thanks Jhocking,

Indeed, I had seen your post and I find it very useful. I tried it out but I think I removed it after checking that Panda sets its own paths in the .bashrc file. Now I don’t remember if I tried Aptana before or after your variables tip :wink:

I’ll do it all over again to see if it makes any difference.

Thanks for replying.
Alvaro F. Celis

Well as I mention in that thread, you really want both the .bash profile and the environment.plist, because the two handle very different things. The .bash profile sets everything to work right when you run Python from Terminal, while environment.plist is for setting up GUI applications.

nothing :frowning:
No Panda stuff gets detected when configuring pydev, only python’s default stuff:

When I try to run any of the examples I get this error:

 File "/Users/afecelis/Documents/Aptana Studio/Panda3d/src/", line 1, in <module>
    import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

So even with the .plist environment variables, native Python is not “seeing” panda’s libraries. :frowning:

The one thing I want to make sure is that you relogged after making changes to your environment.plist because that little detail threw me for a while. Any time you make any adjustments to environment.plist, you have to log out and then back in for the changes to take effect.

Beyond that I have no idea, I’ve never even heard of Aptana Studio before.

Yeah, I read that in your post too. I logged off and went back in hoping to have the newly set env vbles initialized, but it seems it didn’t work.

Funny cause in Windows/Linux by just selecting python’s executable all of the implied libraries get “hooked up”:

and aptana is really something to keep an eye on. It’s great for development in many different languages, but I merely use it for html, lol :wink:
I started using the python plugins looking for a good IDE for python-ogre and panda3d. It’s really great cause you got everything under the same roof, nice code visualization, easy way to run/test your apps, outliner, etc :wink: Everything within the same developing environment.

I’m sure there must be a way to get it running under mac, but it’s a shame it’s a bit more complicated than in the other OSs :smiley:.

Thanks for the interest and help.