Panda3D 1.6.0 Preview for Windows?


I work with Maya 2009 and need the converter in the 1.6.0 Version of Panda3D. Before I start to annoy the admin in my company to install the SDKs (and do the other stuff in the tutorial) so I can build Panda3D with more or less success by my own, I want to ask if there is a working installer (like the one for OSX) that I can download.

I know this question let me look a little bit lazy but I want to try first the easy way.

P.S. in the CVS sources I notice that the makepanda, SceneEditor and the Makefile are in the doc module. But the INSTALL-MK document mention the Panda3D root as their location.

Once you check out the cvs, the dirs in “doc” are moved to the root.

I guess someone with a copy of windows would need to compile it.

i can make 1.60 windows builds…

When completed the build then please post a link so I can download it. My own try to build it end in an error:

c:\Documents and Settings\user name\My Documents\mypandabuild\panda\src\grutil\
openCVTexture.h(23) : fatal error C1083: cannot open file (include): "cxcore.h": No such file or directory

Then I tried to build 1.5.4 and I had success. So it must be a 1.6.0 problem. Because I just need this Maya2009 converter I also tried the option --nothing --use-maya2009 and ended with:

c:\Documents and Settings\user name\My Documents\mypandabuild\dtool\src\interro
gatedb\py_panda.h(52) : fatal error C1083: cannot open file (include): "Python.h": No such file or directory
Storing dependency cache.

Right, 1.6.0 has OpenCVTexture support but the thirdparty package isnt in the 1.5.4 thirdparty packages yet.
You did download the 1.5.4 thirdparty packages, did you? Compile with --no-opencv, --no-squish and --no-fcollada.
The other error looks like you dont have the win-python thirdparty package - verify that you extracted the thirdparty zip correctly.

Well, i didn’t found a third party package for 1.6.0 so I had to use the ones of 1.5.4. The unzip must be correctly because I successfully build 1.5.4.
With the additional options you mentioned a get nearly to end with this error:

link /nologo /NOD:MFC80.LIB /NOD:LIBCI.LIB /NOD:MSVCRTD.LIB /DEBUG  /nod:libc /n
od:libcmtd /nod:atlthunk /DLL /MAP:NUL  /FIXED:NO /OPT:REF /STACK:4194304 /INCRE
MENTAL:NO  /OUT:built/bin/libtinydisplay.dll /IMPLIB:built/lib/
b /LIBPATH:"thirdparty/win-python/libs" built/tmp/tinydisplay_composite1.obj bui
lt/tmp/tinydisplay_composite2.obj built/tmp/tinydisplay_ztriangle.obj built/lib/
libpanda.lib built/lib/libpandaexpress.lib built/lib/libp3dtool.lib built/lib/li
   library "built/lib/libtinydisplay.lib" and object "built/lib/libtinydispla
y.exp" were created
tinydisplay_composite1.obj : error LNK2001: not resolved external symbol ""
__declspec(dllimport) private: static class TypeHandle WinGraphicsPipe::_type_ha
ndle" (__imp_?_type_handle@WinGraphicsPipe@@0VTypeHandle@@A)".

and a lot more of:
error LNK2001: not resolved external symbol
error LNK2019: link to not resolved external symbol

and it ends with:
built/bin/libtinydisplay.dll : fatal error LNK1120: 35 not resolved external links

Sounds troublesome.
For now, edit, locate these lines:

# DIRECTORY: panda/src/tinydisplay/

OPTS=['DIR:panda/src/tinydisplay', 'BUILDING:TINYDISPLAY']
TargetAdd('tinydisplay_composite1.obj', opts=OPTS, input='tinydisplay_composite1.cxx')
TargetAdd('tinydisplay_composite2.obj', opts=OPTS, input='tinydisplay_composite2.cxx')
TargetAdd('tinydisplay_ztriangle.obj', opts=OPTS, input='ztriangle.cxx')
TargetAdd('libtinydisplay.dll', input='tinydisplay_composite1.obj')
TargetAdd('libtinydisplay.dll', input='tinydisplay_composite2.obj')
TargetAdd('libtinydisplay.dll', input='tinydisplay_ztriangle.obj')
TargetAdd('libtinydisplay.dll', input=COMMON_PANDA_LIBS)

Uncomment or remove them all. You just wont be able to use TinyGL software rendering.

It works. Well, the compiling works. I can execute the examples and all other python stuff. But my aim was to use the maya2egg2009 converter, what doesn’t work. First I got all these “I can’t find the maya stuff” errors, so I tried to find a solution in the forum. I used the tip to copy
Then I add the Panda python directory to the PYTHONHOME variable. With that the most error messages where solved, but no egg file were created. Even with the opthion -ignore the converter crashes again. With verbose level 2 I get this:

Initializing Maya.
:maya(debug): Restored current directory to /c/My User directory
:maya(debug): Compiled with Maya library version 2009.0 (200900);
running with library version 2009.
:maya: Reading simple_cube2.mb
:maya(debug): cwd(read:before): C:\My User directory
:maya(debug): Restored current directory after ::read to /c/My User directory
simple_cube2.mb: (kFailure): Unexpected Internal Failure
:maya:mayaegg(error): Unable to read simple_cube2.mb
Errors in conversion.

I know it’s now the wrong forum for this issue and will post this message somewhere else if nobody can give an answer here.

Finally I want to give you some additional information so you can maybe find the reason for the last compiling problem or to update the manual. My admin didn’t install the obsolete DirectX and Windows Server 2003 SDK packages. He used the current versions (DirectX SDK novmber 2008, Windows Server 2008 SDK) which replaced the old versions according to Microsoft.