Panda not starting (no errors)

Hi all,

I never thought my first post would be in installation/starting problem, but it appears to be so. I’ve got Panda3D 1.4.1 installed, and it was running fine before, and from one day on another, it just stops working.

As soon as I start any ppython .py via the command line, it gives me this:

Warning: DirectNotify: category ‘Interval’ already exists
DirectStart: Starting the game.
Known pipe types:
(3 aux display modules not yet loaded.)
:display:windisplay(warning): SetForegroundWindow() failed!

and when I try again, I get a similar thing, but then without the :display:windis… line.

I’ve tried complete reinstalls, and have looked on the internet without luck. I’m now already using the program in a virtual machine environment, but it should work without using that. Anyone got any advice ?

Thanks in advance

It sounds like something in your graphics driver is crashing, or refusing to allocate resources, or something.

But I’m confused. You say it is, or it is not, working in a virtual environment? That’s the one place that Panda (or any 3-D application that requires direct access to your graphics hardware) is generally not expected to work.


Actually, I run panda3D inside VMware all the time. I have to allow software rendering, but other than that, it runs fine.

I’m not sure about the graphics card though, I did an update the other day, and maybe I should try to roll it back or so, but since it are just the latest drivers from the ATI site, there shouldn’t be a problem. I’ll try some of the Omegadrivers, but I think it won’t make a difference.

Hah. There are two kinds of graphics drivers that are particularly likely to have problems: (a) really old drivers, and (b) really new drivers. The latest is not always the best. If it worked with a previous version of the driver, and stopped working after you updated, you should definitely revert.


Already found out what went wrong, I had a VPU error fix patch installed, and it has overwritten files and new and old driver files got mixed up. I just re-downloaded the latest drivers, and it’s working fine again.

Thank you all for the time, info and help.