Panda, Linux, and Nvidia...

I am trying out Panda on Ubuntu- Gusty… I have a Quadro FX 2000 graphics card and am using the latest nVidia drivers (installed with Envy, not the restricted drivers mechanism).

Several of the samples are not working. For example, opens a Panda window, but fails to render. The message given is “Toon Shader: Video driver does not support multiple render targets”.

Is this correct? Does the Nvidia driver for Linux not support render targets in shaders or is this a CG issue? That would make anything but the most basic multi-pass rendering impossible! Does anyone have any info on this. Do I have to go back to windows to get anything more advanced done using shaders?

I had excactly the same problem in Gutsy+nVidia. It might sound odd, but I fixed it when I disabled Xgl.
Try the following commands on the terminal:

mkdir ~/.config/xserver-xgl
touch  ~/.config/xserver-xgl/disable

After doing this (and restarting X), Panda3D ran fine, and so did compiz.

How do I know if XGL is running? I checked synaptic and server-xgl is not installed.

ps aux | grep Xgl

This should show at least 2 lines.
My knowledge stops here. If this doesn’t work, I wouldn’t know.
I have ubuntu gutsy, latest nvidia drivers, but disabling Xgl worked for me.

Apparently I am not using XGL. I am using the 3D stuff in the new Xorg. I have it working now. But panda is still failing to run anything that uses ‘render to texture’.

Any Ideas? Anyone!