Panda is not useable with Linux.

I just installed the latest version of Panda (1.0.4) on a Fedora Core 3 Linux and I encounter several major problems.

  1. several tutorials crash with the following errors:
    AssertionError: Attempt to compute inverse of singular matrix! at line 1501 of built/include/lmatrix4_src.I

  2. some tutorials won’t work properly, for exemple:
    In this case the mathematical functions run correctly but the spheres are not displayed. There are some bad shaped polygons instead.

  3. No way to use the setTexture() call correctly. It only changes the color of the model but doesn’t apply the texture.

  4. Some models provided on this website are not loaded correctly, like the bunny. It looks like a bunch of white polygons pointing in all directions.

Since most of you seem to be quite happy with Panda, and most of you run Windows, I assume that the Linux version is buggy. Can I be wrong ?

Actually, Panda is generally developed first on Linux, then ported to Windows. I run Panda on Linux every day. Several other users on this forum have also run Panda on Linux and report success.

It sounds like there might be an issue with your graphics driver. Are you able to run other OpenGL applications successfully?


i’ve the exactly same problem here on my
fedora core 3 with
geforce4 ti4200 (lates driver- gl setup correctly and working fine)
kernel 2.6.10

seems like parts of the mesh are weld to the objekt center and others where strangly pulled away from it. the greeting card and the first 2 chapters of the solar system sample are working correctly.
and the textures are loaded if you look closely enough… you can see white stripes in the solar system files. caused by a deformated background mesh whitch is dotted with stars (but the points are streched)

4 example… what chess looks like:

other gl apllications are running perfect so i dont think its related to this.

some samples are closing the window after 1 or 2 secs … konsole tells
lots of
Assertion failed: Attempt to compute inverse of singular matrix! at line 1501 of built/include/lmatrix4_src.I
:linmath(warning): Tried to invert singular LMatrix3.

and in the end

Traceback (most recent call last):
File “”, line 129, in ?
w = World() #Create an instance of our class
File “”, line 51, in init
{‘walk’ : “models/eve_walk”})
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/actor/”, line 146, in init
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/actor/”, line 1179, in loadModel
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/showbase/”, line 96, in loadModelCopy
File “ModelPool”, line 137, in loadModel
AssertionError: Attempt to compute inverse of singular matrix! at line 1501 of built/include/lmatrix4_src.I

i installed panda as root… but it shouldnt be a problem… i couldnt install it as normal user and i cant execute it as normal user either (getting :
DirectStart: Starting the game.
enumerate is already present in builtin
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(all display modules loaded.)
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

:display:glxdisplay(error): Could not open display “:0.0”.
Traceback (most recent call last):
File “”, line 1, in ?
import direct.directbase.DirectStart
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/directbase/”, line 4, in ?
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/showbase/”, line 190, in init
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/showbase/”, line 489, in openDefaultWindow
File “/usr/src/redhat/BUILD/panda3d-1.0.4/BUILDROOT/usr/share/panda3d/direct/src/directnotify/”, line 111, in error
StandardError: Unable to open ‘onscreen’ window.

well… i hope there is somone out there who knows what this should mean (i wont care if i have to be root all the time but the first 2 errors are pretty bad)

well. i hope someone can help…

and sorry for such long posts
best greetings


I’ve run Panda3d on a laptop (HP N610c) with Fedora Core 3 so I know it works, well, with my hardware driver that is.

Regarding Linux and root… you should only use root for very few things, one being the installation of new RPM packages.

Are you loggin into the PC as a normal user when your trying to run Panda?

Sounds to me like your logged in as a normal user, however, your trying to run panda in an xterm as root. That could be why your getting the “permission denied” errors.

You can always try completely logging in as root on the GUI until you fix the permission issues.


guess i have to try wich way i can install it without getting installerrors.
-i know it IS stupid like hell beeing logged in as root all the time but like this the engine is working… and i managed to set up my hole system this was and it working fine 4 half a jear so far-this have to wait untli my system is trash and cries for a reinstall^^ but as root there are just the errors Lomion alredy described.
can you tell me your kernel version? might be but i don’t thnink so.
i cant really imagine a reason why meshes should be deformated this way caused by user acc type.
did you build it from source or did you use the rpm?

Thommy, for some reason the X server is denying your normal user access to create an OpenGL context. I don’t know why that is. Maybe you don’t have the right permissions set on your extension file, or on the low-level hardware driver extension?

You might also try executing this command in an xterm shell (as a normal user):

xterm +

although I’d be a little surprised if that fixes it.

As to the polygon issues, it does sound like something’s pretty broken. But it doesn’t sound like thommy and Lomion are experiencing exactly the same set of problems. Can both of you give a complete breakdown of which sample applications work and which don’t, and in what way they fail?

It’s possible there’s something wrong with some of the sample applications; for instance, Eve might be using a matrix that has a very tiny scale, which happens to work correctly on Windows but is detected as a singular transform on Linux–I’ve seen this happen before. I haven’t run any of the sample applications on my Linux box; if you give me a couple of days I can try to get them installed.


I currently don’t have a live Linux system. I reinstall alot and play with things.

I just installed the rpm from the website and I’m using the whatever the default up-to-date RedHat Fedora Core 3 kernel is but the kernel version shouldn’t really have anything to do with this issue, I don’t suspect.

What if you just go to the top level directy where Panda is installed as root and type chmod -R go+rx /usr/local/panda (or whatever the top level directory is).

I’m not sure how much you know about Linux but that may fix up your permission problems unless they lie elsewhere.


the xterm + is causing the same denied access like all the time… but it doesnt really mather 4 me.
a list of the sampel codes and whats working:
GreetingCard- works without errors

basic lessons scene graph 1(planetary system). first 2 files are fine. the other have the strange graphic bug with displaced vertices.but performace is perfect

2nd lesson (carusell) - strange verice placemend again. but rotation and movements are fine

3rd lesson (planetary events) same grafic bugs like 1 but events are working

4 tut robots… poping up window and konsole

5th . texrue animation- --basic tut shows just a black window with text
–advanced tut error message… simmilar to no.4

6th. collision detection… shows a singe square - rotating while movin courser but at very low fps maybe 3-5

7th fog … fine but no textures

8th eve … simmilar to error 4

9th lights … black with 3 coloured deformateted obects truning around slowly (but good fps)

10 network. works fine

11 … steam- teapod missing.
panel- crash and konsole:

  1. picking (chess) screen alreadyposted- deformated mesh

  2. musik plays -grafik error&strange and lots of repeating konsole message: “:linmath(warning): Tried to invert singualer LMatrix3.”

13 tasks - black screen but with text

thats it.
i hope i dont trouble you to much (i know i am)

afterall… it do look something like origami :wink:
thx for all your efforts

thx sm3
but those permission relly shouldn’t be a problem while running it as root.
and thx for the path^^i searched neraly an our but without sucsess… i hope i can try this on my friends pc this weekend. hes updating rh9 to fc3 so a fresh install shouldnt make that much trouble (at least i hope) and if it is working i reinstall everything like in the good old microsoft times… i kinda missed this work anyway :wink:

Ah, well that is true. If your running as root there shouldn’t be permission problems :slight_smile:

Did you install this from source?

Looks like your Python that was previously installed doesn’t have Tkinter. I’m sure Panda will compile without Tk/pmw but the tuts your using are trying to import that module (looks like). At least that’s one of your problems.

i guess phyton was already installed befor.
first i installed the rpm’s. it worked the way it does know (rpms again)
i tried to install it from source, it compiled without errors but i messed around with the path (actually i added the line to the ldconfig and run ldconfig but it didnt work this way^^ ) so i installed the rpm again.

I may reinstall FedoraCore 3 myself today. I’m talking off the top of my head because I’m not 100% familiar with the Linux setup of Panda.

I need to see how it is setup to be of any more help.

It does help to have a clean fc3 install though :slight_smile:

well… you cant call mine clean either^^ it more like… jeah i think its really trashed but its still my first fedora install =) and i did a lot errors while try to install stuff… afterwards you’re always more skilled than before… and errors are the best way to learn (maybe thats why i learn windows in no time =) )

Where does ppython live on your $PATH?

What if you put the PATH for your Panda3d ppython and python in your $PATH before the system Python which is /usr/bin?

Looks like you maybe picking up the system python instead of the panda python first in your path. Panda python having the required modules.

Forgive me, I don’t yet have a fc3 installed. I’m doing that now :slight_smile: You do have fedora core 3 installed correct? Not the rpm panda version but the actual redhat linux fedora core 3?


I have exactly the same problems as Thommy. Same error messages, same things with the planets. I was just too lazy to make screenshots. I tried to make my own scripts and experience strange problems depending on the .egg model I load. cube.egg is fine, bunny is misshaped, sphinx is all right except the texture. In the GreetingCard some textures are all right but the rocks and trees textures are not, only their color is correct.
As for the python binary, I start my scripts with #!/usr/bin/ppython so I guess it can’t be a problem with my previous python installation.
My config is a Nvidia 6800 card with nvidia drivers and usually the other OpenGL applications run smooth.

i guess ppython is the panda python and thats what i tried to run. but it wont work for some reasons.
i mayhave linux for mor than half a jear now but i still ahve problems with those path for all the stuff. gess i relly should read more about his.

the ld config hast the entry /usr/bin
and i dont know where the ppython from the sources was located but the rpm ppython is in usr/bin.
well- i’ll try to ask my friend on saturday.

or if you’re finished before that just let me know it.
i think icq is more kompfortable to solve this problem or this thread will end up in hundrets of pages.
pm me if you like
my nr. 129192572

thommy- i relly should concider to sign up 4 a forum acc^^

Ok, I’m on cd #2 :slight_smile: Its slow, its a laptop :slight_smile:

I’m afraid my attempts to help may be more confusing since I’m not that familiar with how Panda is installed on Linux. I just installed once, fired it up and said, “Yep, it works!”. That was the extent on my Panda Linux adventure.

I do UNIX for a living though, that’s why I thought I may be able to help you. Maybe not :wink:

Hey please if you fix the problem post it here :slight_smile: