Panda and Xcode 4 on Mac

Good Day
I just downloaded the Panda framework and wanted to try to do the first tutorials.

Could anyone help me (if possible step by step) on what i have to do, to be able to code in Xcode 4 (I prefer to code in c++).

I started an empty project and built a new Target (console application) then tried to link the binaries (where Panda is installed the lib folder) but when I compile I get the error that he can’t find:


I tried to install python but still get the error.

What exactly do I need to include and how to get it to work?

Any help would be appreciated

Hi, welcome to the forums!

First of all, make sure you have configured your project to build for i386, 32-bits.
As for your Python.h issue, you might need to add the Python framework to your project’s dependencies. You don’t need to install anything, the Python framework is already on your system. Find and add the Python 2.5 framework.

Also, add Panda’s include and lib directories to your project’s include path and library path.

Thank you for the fast response, I verified that I build the 32 bit version and the i386.

I also added the Phyton framework but I still get this error:

/Developer/Panda3D/include/threadSimpleImpl.h:31:10: fatal error: ‘Python.h’ file not found [2]

Here is what I included:

So what am I missing exactly?

Hmm, you might also need to add /System/Library/Frameworks/Python.framework/Versions/2.5/Headers to your include path.

Thank you for the answer, now this issue is resolved, but i have 17 new errors:

They look all similar to these, what did I miss? I thought I had to build for i386…

Maybe if you could tell me, step by step how you succeeded to make it work on xcode 4 on a mac It would be easier for me to see what I did wrong?

I think you also need to add the Panda3D .dylib files to the project.