Panda 3DS Max 2010 Egg Export Plugin


Im new to the panda engine and the forums.

I’ve been experimenting with converting models using the max plugins, i managed to get the plugin for 2010 working but only when i havePanda 1.7.2 installed. However i want to use Bullet in my project so i’ve switched to the most recent build 1.9.2. The problem is that the plugin which comes with 1.9.2 doesnt seem to work, when i have 1.9.2 installed.

I’m getting the following error on load:

Error Code: 127 - The specified procedure could not be found.

Im using the plugins with 1.9.2 on the 32 bit version, but the only way i’ve been able to get it working is to install Panda 1.7.2, uninstall when im finished using the exporter then installing 1.9.2. Then uninstalling 1.9.2 and reinstalling 1.7.2 when i want to edit models again.

I’ve tried having both 1.7.2 and 1.9.2 installed at the same time but when that happens my program tries to use the 1.7.2 libraries not the 1.9.2 ones, and i get an error.

Only thing i can think of is to use one PC for editing models and one for python work (Not my ideal solution).

If you copy some DLL from the panda3d bin folder into the 3dsmax folder then you can use the importer/exporter without even having the panda3d sdk installed. 3dsmax may use a different version of cg.dll but it should still work ok with the one from panda3d.

I can’t say what files are needed, just copy all of them (but first make a backup!)

Thanks Man

Thats saved me a major headache, like you said i just copied the files from the 1.7.2 sdks bin folder into 3ds Max 2010s plugins directory and then uninstalled 1.7.2

works now

Cheers again