Panda 1.7.2 + Visual C++ 2008 Express

Hi there,

I´m very new to Panda3d and I´ve tried to get Panda3d on VS 2008 Express running. I followed these tutorials:

  1. … in_Windows
  2. … tudio_2008
  3. … _Framework

But after all of that, i´ve got just a console window with this output:

:display(warning): Unable to load: The specified procedure could not be found
Known pipe types:
(all display modules loaded.)
No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.
Could not load the window!

The PATH variable is set correct, I´ve changed the project configuration to release and deleted the NDEBUG macro. Is there something else i´ve missed?

Thanks for help,

The error message seems to say that it failed to load libpandagl.dll, due to some missing dependent library. Perhaps CGGL.dll, or something else related? If that’s so, maybe you need to install the Cg toolkit?

I’m just tossing out guesses. There are other things to try, too. After installing Panda3D SDK, you should have the pview command available to you in a command shell. Can you run pview successfully? If so, it’s using the same graphics libraries, so maybe something’s different about the PATH variable when you’re running your own application. If not, then something went wrong when you installed the Panda3D SDK.

You can also try editing the Config.prc file, changing the line:

load-display pandagl


load-display tinydisplay

If this works, it will allow you to run, but you will be rendering in software-only mode, which is slower and not as good-looking as OpenGL rendering.


Hi David,

thanks for your answer. I took a look into the \bin directory, the libpandagl.dll and cgGL.dll are there. pview is working successfully and the sample programs are working too. I think the path variable is correct, I can call any .exe file in the \bin directory from any path in the command line.

I edited the Config.prc and with the tinydisplay it is working, but I´d like to use a hardware accelerated renderer.

Do you have any other suggestions?

P.S. Maybe it´s not working with VS 2008 Express? Do I need the pro version to run this?

I’m sure that VS 2008 Express works fine, so it must be something else.

It sure does sound like an issue with PATH, though, especially since pview works, and it’s loading the same DLL’s. Can you run your own application from the same command shell that you can run pview from? If it’s only a problem when running it from MSVS, then maybe it’s something wrong with the PATH that MSVS sets up.


I started a new command line and started pview (which works fine) and after that, I launched my sample app from the same command line and I´ve got the same error message…

I´ve also re-installed the Panda3d SDK, but with no effort.

I also played a little bit with the rendering settings in the Config.prc: DX8 rendering works, with DX9, I get the error message from above.

Aaaaaah… I´ve got it!

It seems that one of my applications installed OpenLibraries on my system and added it´s bin directory to the path variable. I think Panda3d tried to load the cgGL.dll (or some other dll´s) from this directory first and this caused the error.