packp3d modules missing

I’m trying to pack an application to a p3d file. So i run this command:

$ packp3d -o app.p3d -d app -m

but i get the following error:

:AppRunner: Total Panda3d disk space used: 169 MB
:AppRunner: Configured max usage is: 2048
There are some missing modules: ['panda3d.bullet', 'panda3d.core']
Generating app-p3d

if i the try to run the produced p3d file i got an ImportError and because i’m running windows right now i can’t copy the error message. I will post it when i start Linux next time.
If i run the app with python it works fine.

Try this:

packp3d -o app.p3d -d app -m -r bullet

So, packp3d will download the package for bullet an include it in your .p3d file. Then the error should disappear.

This gives this output. So i still have the same problem :frowning: .

sven@sven-linuxmint:~/Dropbox/programmierung$ packp3d -d app -m -o app.p3d -r bullet
:AppRunner: Total Panda3D disk space used: 179 MB
:AppRunner: Configured max usage is: 2048 MB
:AppRunner: Freshening
:downloader: [0x2aea660] begin GET [ ]
There are some missing modules: ['panda3d.bullet', 'panda3d.core']
Generating app.p3d

You should ignore the error that appears with packp3d, this is normal. Check if it works when actually running it.

It seems that it is right packaged. There’s still an error that some models aren’t found, but i think i can fix that myself. Thanks for your help :slight_smile: