packp3d issue

I’ve built a very simple app (it’s actually the tutorial) and I want to package it up and display in a web page.

So I’ve used the packp3d command as below:

d:\panda3d>packp3d -o myapp.p3d -d d:\panda3d
:AppRunner: Total Panda3D disk space used: 112 MB
:AppRunner: Configured max usage is: 2048 MB
:stuck_out_tongue:ackager(warning): No such file: /d/panda3d/p3d_info.xml
There are some missing modules: [‘panda3d.core’]
Generating myapp.p3d

I’m obviously doing something wrong, but I’m not sure what.
d:\panda3d is where I’ve put the py file for the app (and the only thing in there is the py file).

Do I need to run this command from a specific directory?


I see no problem. Does the generated p3d file not work?


python works fine.

double clicking myapp.p3d brings up a window that then closes.

Should I be worried about the error:

There are some missing modules: [‘panda3d.core’]


No, it’s normal.

thats exactly the same problem im having, if you figure it out let me know :wink:

It’s not a problem. It’s not causing any problems either. It’s normal behaviour.

shouldnt it be running the application?

That depends on the application, of course. If the code contains an error, then it is normal for the application to quit, and you’ll need to find and fix the issue in the code. By running the p3d from the command-line, you can see exactly what the problem is.

when I run the app the normal way (console ppython it works just fine, when I run the .p3d a black window pops up and then goes away but its not showing any errors

OK, so I’ve created myapp.p3d.

From a command window I type in myapp.p3d, I get a blank screen pop up and disappear. No errors are displayed.

If I use pthon that works fine.

panda3d.core is one of the files in the py file, so I assume it’s important.

Nope, I’ve looked a bit hard and read some other posts.

We need to check and make sure that


works. I get errors about models/environment and that’s what the problem is.

Just need to carry on reading the manual to work out how to fix that.

I’ve copied the models folder from C:\Panda3D-1.7.2 to where my source code is and now it compiles and runs OK.

I tried that but it didnt make any difference, im gonna try remaking the executable again