packp3d error

I’m using Panda3d 1.8.1 Windows and trying to generate a p3d file with this:
packp3d -o test.p3d -d src

and i’m getting this message:
There are some missing modules: [‘ConfigParser’, ‘distutils.core’, ‘panda3d.core’, ‘py2exe’, ‘xml.dom’]

then, i add a -p parameter:
packp3d -o test.p3d -d src -p “c:\Panda3D-1.8.1\python\Lib”

There are some missing modules: [‘Carbon’, ‘Carbon.Files’, ‘_ctypes’, ‘_dummy_threading’, ‘_scproxy’, ‘_xmlplus’, ‘bz2’, ‘grp’, ‘java.lang’, ‘panda3d.core’, ‘py2exe’, ‘vms_lib’]

Do i missing something? i tried other options without success.

Thanks in advance.

These warnings are expected and can be ignored. If you want to use more than just a basic subset of the Python standard libraries you can use “-r morepy” (but I advise only adding that if you actually get errors running the .p3d file).

Thanks rdb.
Using my last example, when i run “panda3d test.p3d” im getting this error:

from ctypes import *
File “VFSImporter”, line 153, in load_module
File “c:\Panda3D-1.8.1\python\Lib\”, line 10, in
from _ctypes import Union, Structure, Array
ImportError: No module named _ctypes
Failure on startup.

I have no problem running the app from my dev directory. I’m using Python standard libraries and my only python installation is with Panda. Also i see the folder c:\Panda3D-1.8.1\python\Lib\ctypes\ on my installation.

You should not use -p to add your Python directory. Have you tried “-r morepy” ?

Thanks rdb!! the “-r morepy” do the trick.
Now with the .p3d i’m trying to test the app with “panda3d test.p3d”. The app is using multifiles and is not finding them, i got this error:

:express(warning): Attempt to mount mydata/, not found.
The structure is:


In the p3d file i only have to code. I have to add the folder with the multifiles or something like that?

Thanks again.

You may have to use -e mf (store compressed) or -n mf (store uncompressed) to make sure that .mf files are included in the .p3d file.

I tried with -n and -e and got the same warning.

After the packp3d I want to use pdeploy to create an installer that create an structure like this:

panda dlls, folders, etc.

I tried to create a p3d file with just the code, then generate an installer. When I install the app and manually copied the folder with mf files, the structure look similar to the above but doesn’ t work, i can’t see error messages but i think the problem is the same, it can’t access the mf files.

So when you use -e or -n to include the mf file, the output of “multify -tvf something.p3d” does not include the mf file?

The p3d file include the mf file. I can see it in the list.
I found a similar problem (nested multifiles) David talked about the problem and to use ppackage but i didn’t find documentation about it.

Anyway, i just need to get a working folder with my app, i mean, the mf files, a generated exe and panda dlls and other dependencies. Is there any other (maybe manual) way to do that? its a desktop windows app.