Packp3d - Cannot Read Self Signed Certificate

I’m looking to sign my p3d application with a self signed certificate. However, when I pass the signature into packp3d I just get the following error:

:AppRunner: Total Panda3D disk space used: 155 MB
:AppRunner: Configured max usage is: 2048 MB
There are some missing modules: ['panda3d.core']
Generating test.p3d
:express: Could not read C:\Users\<Username>\Desktop\cert.pem.

The process that I went through to create the signature is what was said in the manual, using openSSL and having both the private and public key in the same file.

Thanks in advance, any help would be appreciated.

Perhaps it simply can’t find the file? Can you try putting it in the current directory and referencing it with a relative path?

Thats what I had thought as well, but the command to run packp3d should have taken care of that. Below is the command that I used to run the program…

"C:\Panda3D-1.8.1\bin\packp3d.exe" -d "C:\Users\<Username>\Desktop\Computer\Game" -S C:\Users\<Username>\Desktop\cert.pem -o C:\Users\<Username>\Desktop\test.p3d

I think it may have something to do with the way that the the output is captured from openssl as the cert that I’m getting out has the following structure…


Which seems somewhat arbitrary. Is this the correct format for the file or am I doing something wrong when I make the file?

Can you try using a panda-style path to -S, like /c/Users/<username/Desktop/cert.pem, just to rule that out?

Thank you! That solved my problem

The command that I used to run the program was this…

packp3d -o C:\Users\<Username>\Desktop\test.p3d -d "C:\Users\<Username>\
Desktop\Computer\Game" -S /c/Users/<Username>/Desktop/cert.pem

This let it finished and I see the certificate now when I run it in browser.

Thanks again