OpenGL Version issue

Wehn I try to use the ‘pview’ method to preview models I get this error: :display:gsg:glgsg(warning): Driver possibly misreported GL_VERSION! Unable to detect correct OpenGL version. So, nothing will render. I am running OpenGL 4.5 on my machine. Any suggestions on how to fix this?

First make sure your drivers are up-to-date. Could you please tell us what OS and GPU you are using?

I have updated all of my drivers. I am using Windows 10 on a Dell precision 7530. The GPU is the one that comes standard with it (this is my work computer). I’m pretty sure it comes with an NVIDIA Quadro P3200.

With an error like that, I was expecting an Intel card. Does your laptop use Optimus (i.e., have both an Intel and an Nvidia card)? Is so, you may need to force pview to use your Nvidia GPU. I believe this can be done via the Nvidia control panel.

I don’t see any other card that it might be using. In the NVIDIA control panel I have the OpenGL Rendering GPU set to the Quadro P3200 as well.

Nevermind there is an Intel card. It looks like from the NIVIDIA control panel under the PhysX settings that it is using the intel card currently

Are the drivers for your Intel card up-to-date as well? We can try getting things working with your Intel card, or we can try and get the Optimus drivers using the NVIDIA GPU. The Intel card is likely strong enough to view models with pview, so it could be nicer for battery life.

I think I’d rather use Optimus since I will eventually be doing more with the models I’m just trying to get started at the moment.

There are options documented here for getting the Optimus driver to pick the NVIDIA GPU. Options 4 and 5 are unavailable to you (they require changes to Panda itself), but you can try some of the others.

Maybe I will have to make it work with my Intel card. I’m getting the same error and after I changed the global settings to select the NVIDIA high performance processor.

The warning can be ignored. It has nothing to do with Optimus, and in fact, Panda is using the dedicated NVIDIA card here. The problem is that the NVIDIA driver behaves incorrectly for processes named pview.exe, by returning a very old OpenGL version number. It does not do this for a different process name. Panda3D detects when the NVIDIA driver does this, and corrects for it by using a different way to query the OpenGL version.

The warning should not result in nothing rendering. If you see nothing render, that is a different problem. (Press shift+L to see if there is anything in the scene at all, or C to center the camera on the model.) But if you wish to remove all doubt, you could rename pview.exe to a different filename.