OpenAL crash in 1.9.0 64 bits


I use version 1.9.0 64 bits on windows (version Panda3D-1.9.0-x64-2014.1.27-503). I have a complex configuration, where I use 3 versions of ppython.exe (a left, middle and right version) to run three channels for 3 displays. In order to optimize performance, I run these on different processors. In the 32 bits version I could simply set each version to a separate processor with imagecfg, but in the 64 bits version of panda that’s not possible anymore. So now I use psexec to set the affinities.

The problem I encounter, is that on some computers occasionally the following error occurs:
the renderer crashes when started by psexec with the following message:
:audio(error): OpenALAudioManager: No open device or context

I know this issue also sometime occurred with panda 1.8.0 and seems to have been solved later, but now I have it again. The computer on which this occurs has an onboard sound chip (no separate sound card).

When I start panda with this:
start /MIN /NORMAL c:\Panda3D-1.9.0-x64\python\ppython_right.exe
start /MIN /NORMAL c:\Panda3D-1.9.0-x64\python\ppython_left.exe
start /MIN /NORMAL c:\Panda3D-1.9.0-x64\python\ppython_center.exe

then there’s no problem or OpenAL error and all works fine, except that I can’t set the processor affinity of the three processes.

When I start panda with this:
psexec -d -normal -a 3,7 c:\Panda3D-1.9.0-x64\python\ppython_right.exe
psexec -d -normal -a 2,6 c:\Panda3D-1.9.0-x64\python\ppython_left.exe
psexec -d -normal -a 0,4 c:\Panda3D-1.9.0-x64\python\ppython_center.exe

I get this OpenAL error on some computers most of the time (not always).

Does anybody know what could cause this ?

I noticed that the OpenAL32.dll file in the latest version of Panda1.9.0 is not the same as the OpenAL32.dll file in Panda3D-1.9.0-x64-2014.1.27-503. So I replaced this with the latest version of OpenAL32.dll, and this solved the issue.