obj2egg help

I’ve gone through the forum, but I cannot figure out how to get obj2egg to work.
I type in: obj2egg.py -n30 -b -t -s file.obj
and nothing happens.

I’ve tried it in the bin folder of panda with my obj file in the same folder
I’ve moved the obj2egg file and my files to the folder containing the python command
I guess I don’t know what I am doing. I would appreciate any help that I can get.


Let me reiterate my problem. I can get obj2egg to run now, but it keeps telling me that it cannot find my source file. Where should my source file be? I have it in the same folder as the obj2egg file.


Nevermind. I got it too work, although I thought it was Treeform’s version that is supposed to include textures. When I realized that it wasn’t, I went and found his, but when I run it the Terminal just blinks at me.

Anyone know a fix for that?

I’m actually having a different problem. Can’t get it to work with the ‘tangent’ (-t) argument.

However, this does work…

ppython obj2egg.py -n30 -b -s king.obj

Perhaps I have an old version without tangent support? Anyone have a link? Thoughts?

You can also generate tangents after the fact, using the egg-trans program, if you have issues generating them using this script.