Nvida graphic required?


Does the panda3d required computer having Nvida graphic card?

My do not have Nvida graphic and it complain that

 StandardError: No graphics pipe is available!
 Your Config.prc file must name at least one valid panda display
 library via load-display or aux-display.


There is nothing in Panda that requires NVidia brand graphics card. We do require some kind of 3-D acceleration, but virtually every computer nowadays has that.

This particular error refers to an installation problem in Panda3D itself: it should have loaded Config.prc, which specifies either pandadx9 or pandagl. For some reason that didn’t work. This has nothing to do with the quality of graphics hardware in your computer.

What kind of system are you running on (Mac or Windows), and where did you download Panda from?


I am using iMac with version 10.5.5.
I download the private build for Mac OSX.

Which private build? There are several on the forums, do you mean this one?

This error usually can have one of three causes:

  • Your Config.prc file did not get loaded. In the build linked above, it can be found in /Applications/Panda3D/1.6.0/etc/. If this is the problem, you can workaround by doing:
export PANDA_PRC_DIR=/Applications/Panda3D/1.6.0/etc/
  • The Config.prc file contains no plugin-path variable. Edit your Config.prc file with a text editor, scroll all the way down, and it should contain the plugin-path pointing to Panda’s lib/ directory. If not, you should add it.

  • Or, less likely, but possible, libpandagl.dylib failed to load. It can be found in /Applications/Panda3D/1.6.0/lib/, if python fails to load it it might throw the error as well. Or, maybe your DYLD_LIBRARY_PATH wasn’t set correctly. If you’re using the dmg in the link above, the accompanying script should fix the library paths.

Did you get the error when running “pview” or when running a python app that uses panda? Could you try running ‘pview’ to see if that works?

Hi, this is the error I got when running pview:

tak-dragon:~ techinkang$ pview
Known pipe types:
(all display modules loaded.)
:display(error): Could not get requested FrameBufferProperties; abandoning window.
requested: depth_bits=16 color_bits=16 alpha_bits=1 back_buffers=1 force_hardware=1
got: depth_bits=32 color_bits=15 alpha_bits=1 back_buffers=1 force_hardware=1
:framework(error): Unable to create window.
tak-dragon:~ techinkang$

Trying using python statement (from another post):
Got a BLANK window without anything. And the running wheel is running.

Here is the log:

ak-dragon:~ techinkang$ python
Python 2.5.1 (r251:54863, Jan 17 2008, 19:35:17)
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

import os
import re
[(x, os.environ[x]) for x in os.environ.keys() if re.match(‘DYLD.*’, x)]
[(‘DYLD_LIBRARY_PATH’, ‘/Applications/Panda3D/1.6.0/lib:’)]

from direct.directbase import DirectStart
DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(all display modules loaded.)
:display(warning): FrameBufferProperties available less than requested.
:util(warning): Adjusting global clock’s real time by 1.41376 seconds.

from pandac.PandaModules import *

I’ve seen this more often lately – can you try editing your Config.prc and lowering your color-bits a bit? At least that worked for me.

drwr, this seems to be something you recently checked in. I tried building both an 1.5.4 build and 1.6.pre build on mac, where the former worked, but I needed to adjust my bit settings to make it work on the latter. I’m not entirely sure it’s this file though, it just seems likely. Other users have also reported this problem.
A potential solution would be to modify the default Config.prc and lower the bits, but this output seems wrong anyways:

requested: depth_bits=16 color_bits=16 alpha_bits=1 back_buffers=1 force_hardware=1
got: depth_bits=32 color_bits=15 alpha_bits=1 back_buffers=1 force_hardware=1 

Is it usual to get just 15 color bits on Mac? :slight_smile:

change color bit to 15; run pview ; an OK. move the triangle, and it disappear.

How do I start up the pand3d program? I can not find it in my system.

You can’t “run” panda3d, it’s a library, not a program.
The first few pages of the manual explain everything.

Ah, interesting! I’ll investigate.