Not able to creat .p3d files [Solved]


When creating a .p3d file, I got this output:

I did install the runtime and adapted my var path and also copied the packp3D.p3d from and placed it in Panda3D-1.6.2/bin.
What did I miss ?

Either get packp3d.exe, which is shipped with the SDK build, or run it with “panda3d.exe packp3d.p3d” instead of packp3d.exe.

Where is packp3d.exe ?
Searched it everywhere and it’s not in any 1.6.2 directory nor runtime install!

Also, neither “panda3d”, “panda3d.exe” or “packp3d” command work, they all generate the error message above.
“packp3d.p3d” generate the following message:

You need 1.7.0 for this feature; it’s not part of 1.6.2.


Ok, I upgraded to 1.7 but stil not able to make any p3d file.
I removed and re-installed everything (SDK + Runtime) and downloaded that 28k packpanda.p3d many time (just in case one was corrupted).
At least when I try, I don’t have any error message but cmd give hand back as nothing happen like that guy
What did I miss ?

Can you run panda3d.exe? If not, then you need to solve that problem first. This program is part of the Panda3D runtime, and it should be installed in c:\Program Files\Panda3D.


No, I can’t execute panda3d.exe --> “the system can’t execute the specified program”

I installed the runtime by default on c:\Program Files\Panda3D
That’s what I wanted to show by putting the the pat’s window on the screenshot.

So, we need to figure out why you can’t run panda3d.exe.

What happens when you try to run it? Does it just immediately exit without any error message, like your attempts to run packp3d, in the screenshot? If so, that sounds suspiciously like the side-by-side assemblies problem.

If that’s the case, then perhaps you need to install the appropriate manifest file. Installing the .NET framework has been reported to do this.


If I try ‘panda3d.exe’, I got the following error:

I just complete the installation of the .NET framework which didn’t help.
Same error message even if I run the command from runtime directory.

What happens if you install the MSVS 2008 express edition?


That was it David. Installing Ms VS 2008 make panda3d.exe working and I was also able to generate a p3d file. Thanks :slight_smile:

OK, so that does prove that we do still have an issue with manifest files somewhere. :frowning: