Normal Issues

Hi folks,

i used to model in 3dsmax but since i am using panda for a college project i started using Blender. I had a lot of trouble getting used to blender interface and im still having some minor issues.

After exporting my model to EGG i saw some normals error. (at least i think it is normals). This normals thing in blender (recalculate normals, flip normals) is pretty messy. :frowning:

Is there a way to know where the normal is facing?
Here is my models SS, note that some triangles disapear at some angles. … panda1.jpg … panda2.jpg … panda3.jpg

Hope that someone can help :slight_smile:

The simplest way is probably just to enable the option to view normals (and set their length, if appropriate). To do this, go to the Editing section (via the icon or via F9) of the Buttons Window, go to the section labelled “Mesh Tools More” (in 2.46; it might be under a different title in other versions) and click on the button labelled “Draw Normals”. Note that there also exists a button to “Draw VNormals” (i.e. vertex normals), but I think that it is the face normals, which should be shown as a result of the former button being depressed, that are important.

Otherwise, in a textured preview (either by setting the draw mode to “Textured” or enabling “Solid Tex” in “View Properties”, itself found via the View menu of the 3D view) you should, I think, tend to find that faces whose normals are facing the wrong way are invisible or partly-visible (the latter if they’re selected, I think), but show up normally from the other side.

Blender can indeed have a bit of a steep learning curve; I recommend this tutorial as a learning tool, from my own experience. :slight_smile:

thanks a lot for the tips!

unfortunately it wasnt the error… now i have no clues :frowning:
this is the SS of blender and the bird normals. … panda4.jpg

my blender version is 2.46

  • the texture is showed correctly inside blender. The problem is the tris :frowning:

The clues are my pleasure. :slight_smile:

Hmm… I’m not sure then, I’m afraid. :confused:

Which parts, specifically, go missing? I’m finding it a little hard for to confidently spot the missing sections using those screenshots, I’m afraid. ^^;

Thaumaturge thanks a lot for your help :slight_smile:

i uploaded the egg file so u could see by yourself hehe :slight_smile:

i tried exporting with chicken R44 too but occurred the following error:

You must specify the egg file(s) to read on the command line.

  egg2bam [opts] input.egg output.bam
  egg2bam [opts] -o output.bam input.egg

Traceback (most recent call last):
  File "<string>", line 1279, in <module>
AttributeError: no such file or Blender text

Aah, I think that I may see.

Your model seems to be set up to render as though it contained transparency; in particular, it looks as though the option “alpha { blend_no_occlude }” prevents occlusion writes, causing the polygons to presumably render without writing to the z-buffer in order to mark their distance from the viewer, and thus overwriting previous polygons within the object without regard to whether the new polygon should be before or behind any others in the object.

As to the error with R44, that seems odd - are you using it from the console, or from within Blender?

Youre right! I tried a lot off different configurations but i still cant use my TGA (with alpha channel). Is there a way to use only one image for Diffuse + Alpha or i will have to divide this in 2 maps?

This chicken error happens when i click in export -> Chicken R44

thanks for your patience

Hi i could make it work! :slight_smile:

After searching for this error i found this topic: … hlight=tga

the error is in the TGA format! So i converted the image to PNG and erased the “alpha { blend_no_occlude }” line from the egg. By the way, what is the blender conf that generate this line? :blush:

I’m glad to hear that you have it working. :slight_smile:

I honestly don’t know, I’m afraid. :confused:

I don’t think that I’ve had it turn up in my eggs.

Hmm… You seem to be specifying a material. You don’t have transparency enabled in your Blender material, do you?

That’s very odd, it seems to me. It looks as though it’s attempting to run egg2Bam, but that should surely only happen if you attempt to export with the egg2Bam button depressed, not during startup of the script. o_0

It also appears as though it’s attempting to read a string from Blender that does not exist. I had a similar problem, as I recall, but I seem to think that I was given line numbers within the Chicken script, which allowed me to hack around the problem…

Perhaps there’s an odd bug in there somewhere - perhaps someone with more experience with Chicken might be able to enlighten us…