No textures with .X problems - Need help ASAP


A little background, I'm 14 years old, and am doing a project for my ELAR class, which involves me making a 3D interactive story. I've got everything down, but I'm not a modeler, and havn't messed with it a whole lot.

This time, I got GMax, and set up the exporters to get a .X file. I made sure to check No Compile, and the Save X File options. I clicked go, and it saved, and I pviewed it. It was prefect, except that there were no textures.

When I went to edit the names, I ran into some problems, so what I did, was on every plugin that I moved over that had an .exe in it's editable filename, I got rid of it, so it's still an .exe, just not in the filename, AKA it can still be run fine. That fixed my problem, but I've got this new one. I was wondering if I need a .exe on one, or if I need to include something, or whats the problem.

We need to figure out where the problem is. Either GMax didn’t export the textures into the .x file, or the textures are in the .x file but Panda wasn’t able to load them for some reason when you tried to pview it.

The first clue to look for is to see if your texture files are listed somewhere within the .x file. Just open the .x file in a text editor and search through it for your texture filenames. You should also check whether the pathnames appear to be correct. If the texture files are not listed, then it must be a problem with the exporter.

If the textures appear to be listed correctly, then watch carefully for error messages when you pview the .x file. Does it complain about not being able to find the textures, or not being able to load them because they’re an incorrect format? If you see any error messages, they will probably give you a clue.

If the textures are listed, and you don’t see any error messages, but you still don’t see the textures, there must be some other problem. You can try to run a command like:

x2egg -o output.egg input.x

to convert input.x to output.egg. Then examine output.egg to see if it lists the textures and that the paths seem to be correct (it should be a relative path from the egg file).

Also, try pviewing some other egg model, for instance panda-model.egg, which comes with Panda. Can you see the textures on that file? If you can’t, there may be a general problem with Panda or with your graphics driver. For instance, there was a version of the NVidia driver a while back that simply wouldn’t load textures in OpenGL mode.

I’m sorry, I have no idea what you’re talking about here. Of course, I know nothing about GMax or its plugin system. But I’ve never heard of a need to rename the .exe extension off of a program.


^^ Thanks!

I checked the .X, and turned out, that for some reason it was saving the images as .bmp’s, and not jpeg’s, and once I fixed that it was working perfectly.