No module named etree.ElementTree [SOLVED]

I use “from xml.etree.ElementTree import *” to deal xml files,but cannot find the module when run p3d.

  File "VFSImporter", line 153, in load_module
  File "E:\tmp\3D Engine\w_panda3d\xcc\src\", line 2, in <module>
    from xml.etree.ElementTree import *
ImportError: No module named etree.ElementTree
Failure on startup.

I had add -r morepy:
packp3d -o xcc.p3d -d xcc -r fmod -r morepy -n avi

Hi, could you post a small example which reproduces the issue?
I tried this file:

from xml.etree.ElementTree import *
import direct.directbase.DirectStart
root = Element( 'html' )
print root

I packed it with:

packp3d -o xcc.p3d -r morepy

and when I launched it, as expected:

$ panda3d xcc.p3d
<Element 'html' at 0x41a38b0>

(I am using Panda3D 1.8.0).

Thanks a lot.
I tried times, and it did.
But before this, I did get the error above. First time I didnot add “-r morepy”, the message was “No module xml”; after I added, the message was “No module named etree.ElementTree”.But now, it was really ok.Confused.