No graphics pipe is available!

I’m trying to get Panda3D working with Komodo, my choice of IDE.

I can run any of the samples fine, but when I try to run via the ide I get the error.

StandardError: No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

From an interactive shell, I can query the following…

from pandac.PandaModules import *
print ConfigPageManager.getGlobalPtr()
0 explicit pages:

2 implicit pages:

print ConfigPageManager.getGlobalPtr().getSearchPath()

I’m stuck here really, the samples wortk so I know my system has what it takes, but clearly I’m missing something.

Any ideas ?



just set the python path in edit->prefferences->languages->python to /bin/ppython.exe

Thanks, that worked.

Though it has b0rked my normal python work, so I still have some playing to do.

So what is ppython ?
I read it checks some paths, but clearly something else is happening too.

I’m looking forward to diving into panda3d so, I may end up moving my normal external modules into panda’s python folders.

I have written code which relies on numarray.
when i install numarray it was to install to c:\python24, and I can’t alter that.

I need to be able to use modules with panda’s python.

If i understand it correct:
ppython checks the paths for the Panda3D libs.
You can move the Panda3D sources to your normal Pythonfolder
Please correct me if im not right

in kodo you can select which python version you want to use, just use ppython for one, python24 for the other.

To add numpy to panda’s python version, simply copy paster the numpy dir from



That’s great.
I though I had tried that…ah, it was a late night.

sorry to bring up such an old topic but i also want to use komodo with panda. but in my bin folder i do not have a ppython.exe
plus it does not load the prc file. it does work if i have loadPrcFileData in the actuall script which i do not want.

I dont know for Komodo.

However the “ppython.exe” does not exists because it’s no more needed for Panda3D.
You can use the python.exe in the Panda\Bin folder everywhere you was thinking about using “ppython.exe”

there isnt a python.exe only a dll

I’m trying to run the simple C++ version of “Hello world” from manual and I got the same problem.

I’m running Panda3D 1.7.0 on Windows 7 x64 and compiled via VS2008. Sample codes runs perfectly. Python version of “Hello world” run correctly too.
Any idea what it should be?

I have same problem. Using Win7 x64,VS2008.

Me tooo … please help somebody … :frowning:

Please make sure your graphics drivers are updated to the latest version. And please don’t double-post.