nightly build error (duplicate)

first it’s great that we have that feature now :slight_smile:

i’d suggest putting the link for the nightly builds on the download page as well.

now to the real error:
i’m not completely sure if this is a bug that’s related to older installations of panda3d, but using the nightly build installer, disabling the “remove 1.6 panda” option, activating the “add sourcecode” option made the “remove 1.6 panda” option go away. also it’s not adding the required exports into the .profile anymore (or if it did, it’s the wrong content).


Hm, I’ll take a look. The “Remove Panda3D 1.6” option is temporary though, I put it in there to make it clear that Panda 1.7 is not likely to work correctly with 1.6 still installed, because everything about the OSX installation has changed.

I no longer use the hacky .bash_profile changes, you should remove your old ones from it (the “remove 1.6” option does this for you, with a big regex). Instead, it writes some paths to ~/.MacOSX/environment.plist, although I’m trying to phase that out as well by shipping Panda3D as a framework, I didn’t get to doing that yet though. I’m trying to get rid of these path settings because they are per-user, and the Panda installation is system-wide.

For the record, Panda3D 1.7.0 installs itself into /Developer/Panda3D (it actually contains symlinks to the right directories like /Developer/Examples/Panda3D and /Developer/Tools/Panda3D).

i’ve just googled a bit and encountered this:

as adding the exports to ~/.MacOSX/environment.plist will be a user setting as well, it seems reasonable to use this approach. but i havent tried it myself yet. also it seems that it needs to be set using “setenv”, not only defining the variable.

What do you mean, using setenv? environment.plist is a plist file, thus XML. It’s not a shell script.

Do the sample programs in /Developer/Examples work for you? (Of course, you need to remove 1.6.2 at least from the paths.)

i have changed my .bash_profile so it has panda in the path, without that change it did not run (with log-out-in).

you’re most possibly right with, i first thought that /etc/launchd.conf is a xml file as well…

That sample is talking about launchd.conf, and that’s not a plist file.

Can you please be more specific and tell me what the problem is you are having now?

the entries that are added into the environment.plist dont work, that’s all i wanted to report.

dont work = panda is not in the pythonpath etc.

Well, but what is the error you are getting when running the samples? Are the Python modules not found? Are the C++ libraries not found? Or do they fail loading because their dependencies are not found?

Are you having the same issue as kaweh here?

oh, sorry, i didnt see that thread. yes it’s the same error.

Ah. But if its the same error, the Panda libraries are on the PYTHONPATH, just not on the DYLD_LIBRARY_PATH. Phew, I thought we were dealing with a new issue here.