Newbie needs help?

I recently downloaded the Panda3D engine, and then used PYPE program to begin using it.

When trying to run the second script:

import direct.directbase.DirectStart
#Load the first environment model
environ = loader.loadModel(“models/environment”)
#Run the tutorial

I see this in the PYPE program as the file is running…

DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(all display modules loaded.)
:display:gsg:glgsg(warning): Buffers advertised as supported by OpenGL runtime, but could not get pointers to extension functions.
:display:gsg:glgsg(warning): Occlusion queries advertised as supported by OpenGL runtime, but could not get pointers to extension functions.
:util(warning): Adjusting global clock’s real time by 1.21593e-005 seconds.
:util(warning): Adjusting global clock’s real time by -0.676374 seconds.

I end up with a greyish screen, not showing the grass/rocks…I do realize it is a OpenGL problem, I do not know if I have a decent version of a OpenGL…Any help that is offered will be accepted!!!

Hmm… Well, have you downloaded the latest drivers for your graphics card? For that matter, what graphics card do you have, and what operating system are you using?

I am using Windows Vista 32bit, and my graphics card is Mobile Intel 965 Chipset Family, I tried downloading the newest possible drivers, which didn’t help sir. I am running Dual Intel Pentium 1.6ghz core…

Hmm… I’m not sure, in that case, I’m afraid.

A little digging did produce the note that, if I was looking at the information for the right device, your card should only support OpenGL up to 1.5, but I would imagine that you should still be able to render relatively simple geometry…

The only other item that I found, and that I think is worth passing on, just in case, is that, according to a page on the Intel’s support site:

Thus, if you got your drivers through Microsoft, perhaps try doing it through Intel instead.

Otherwise, unless something new comes to mind, or new information comes to light, I defer to other members of the forum, some of whom hopefully have more knowledge on this topic than I.

Thaumaturge’s advice is sound–make sure you get the best drivers directly from Intel.

Failing that, you can also try running in DirectX mode. Edit your Config.prc file to change:

load-display pandagl


load-display pandadx9

or even:

load-display pandadx8

Also, are you 100% sure that the environment model should be visible if you parent it thus? Are these the numbers that the sample gives? What happens if you just run the pview command–do you see the blue triangle?


Thanks everyone for the prompt, and very descriptive responses. After trying to run several sample programs, a couple of them tell me that my graphics card isn’t powerful enough to run character shading, etc.

I also tried what you suggested Thaur, I switched Pandagl to Pandadx9, and I still do not get any picture when I run the script provided in the manual section of panda reference. I am thinking I will have to put off on
using Panda3D until I can afford a decent desktop, since mine was stolen while I was in the military snore. But once again, thank you all whom has offered your knowledge, and those who did research on my behalf. I might still surf the forums and ask question even if I don’t have Panda3D!

idk but does the prebuild ones of panda work for you? if so then its somthing else. I had this happen befor but sorta forgot why and how I fix it.