new user - textures and sound library problem


I just downloaded Panda3D to give it a go and I’ve got a couple of problems. The textures won’t render and the sound library won’t load, either from the sample executables or from the command line script executions. I got the best messages from running the python scripts from the command line. Either way, I get a messagebox about the sound entitled:

PANDA: Python.exe - Entry Point Not Found

The procedure entry point_fsound_stream@16 could not be found in the dynamic link library fmod.dll.

I found the line for fsound_stream@16 in the fmod.dll, I don’t know why the program can’t find it.

From the command line I got this as well:

audio load library<> failed - will use null audio manager

Now, as for textures/models when trying to run the complete solar system script. On the command line I got this error:

:display:gsg:glgsggl texture failed for (1 for each texture name):invalid operation

:display:gsg:glgsg: at 3420 of d:\temp\mkrp\panda3d1.0.4\panda\src\glstuff\glgraphicssatateguardian_sfc.cxx: invalid operation

Now, the last error makes sense, as that path does not exist on my computer, but the question is, where do I find that path to correct it? is the .py script editable in notepad? I assume that where that path is located, but we know what assumption can do for you.

I am a vb programmer with a smattering of dabble with vc++ and python is new to me. I took a gander through the header files and so forth. Pretty normal. Should be able to sort this out.

I have a geforce4 440mx SE vid card that does not support pixel shading or bumpmapping. Gotta love eVGA.

Any help on how I can attack these issues would be greatly appreciated.

Thanks a bunch!

Hi Steven,

The texture issue is an easy one. You must have a broken version of the NVidia graphics driver; there was a version that could not load textures in OpenGL mode. You will have to download and install a more recent driver from

The sound issue is a little harder. Is it possible that you have two different versions of fmod.dll on your system? Try doing a find to see if more than one of them turn up.


Hmmm, I am not using the latest driver, because i wasn’t happy with the performance once it got into the 60 series, but I have never had an opengl problem before. I’ll give it a try, though. Certainly can’t hurt. I still have the 62-something installer on my hdd. Just have to double-click it.

Unfortunately I’m at work right now, but I’ll update that driver and do a search for the fmod after I get home in the morning.


Oh yes, can you work on python scripts in notepad? I have a couple nice freeware code editing programs that might work well too. I just haven’t tried them out yet.

Anyone here have a preference?

Another option, if you are reluctant to update your drivers, is to force DirectX rendering instead. Edit your Config.prc file to modify the line:

load-display libpandagl

to read:

load-display libpandadx8

instead. But I do recommend updating your drivers; you’ve got a particularly buggy version. :slight_smile:

You can use notepad, or any text editor, to edit your Python files. Notepad isn’t very powerful, but it does the job. I prefer Emacs myself, which is quite possibly the most powerful editor out there, but it’s not very friendly and it has a pretty steep learning curve (I use Emacs mainly because I have used it for the past 15 years on various Unix platforms). Most people find their own preference before long.

I’ll give that go as well. I’ve always prefered directx to opengl anyway.

You know, I have never been afraid to update my drivers for anything. I’ve always been of the mind that newer must be better. Then I ran into all kinds of funny little glitches. Course, that might have been related to my upgrade from winme to winxp as well. Bad mix. Hdd crashed. Lost a lot of stuff. I’ll probably just skip the driver I have and go right for the throat. They must have an even newer version by now.

I have Crimson Editor and I am downloading PSPad from Snapfiles. it says that it’s pre-configured for Python. This is going to be fun!

Terrific! I swapped to DirectX and I have my textures. I also swapped to fullscreen. I like that much better. I can see okay, but while I don’t have sound, I didn’t get the error dialog either. Just no sound. My next task is to upgrade the driver and see if OpenGL works, then I have to track down the fmod issue. Thanks so much for your help. I’ll report back as I progress.

Heya Steven8!

I had the same fmod/sound issues. I think there was an old version in my windows directory that was being found. Once I replaced that with the version that Panda3D had, the sound came up just fine. :slight_smile:

Good Luck!

Well, you just answered my next question. I found fmod.dll 3.7.2 in my system32 directory and the one panda wants is 3.7.3. I was worried that it might impair the original program looking for 3.7.2. If this is not the case, I’ll swap it right over tomorrow.

Also, upgrading my driver got the opengl working. :smiley:

Thanks so much to everyone for their help. Once I get comfortable with the code, we’ll se what we can do about making some mods!!!

Okey-doke. I’ve got sound now. I ran the music box sample to test it out. Excellent!!

I download py2exe for python 2.4 and I am now d/l’ing python 2.4. Panda will work okay even though it came with 2.2, won’t it? or is independent of that?

Unfortunately, when you compile a C++ library (like panda) for python, you have to choose a python version. The version I ship here on the website is compiled for python 2.2. It’s not hard to compile it for 2.4. However, there are a few small changes in python 2.4 that cause incompatibility with panda. Nothing we can’t work around, but we just haven’t done it yet.

That’s okay. It’s just needed to run py2exe. My Panda stuff all runs just fine. The engine does very nice stuff. I’m looking forward to working with it.

I downloaded PSPad from Snapfiles. It seems to be a very nice little code editor.