New Environment Not Showing

I’m using Panda3D as a kind of SLAM for a robotics application. I’m attempting to create a static environment for testing, and I created by file in C4D, exported to Blender, and then used the YABEE exporter for my environment to go to .egg format. I tried both the .egg file, as well as a converted .bam file.

The environment consists of a flat cube object turned into a plane. It has a table, and a box sitting on the table. That’s it in the scene.

However, when I load the environment, it just gives me a blank grey screen.

There’s not much documentation at the moment on environment creation. Do I need to have a camera in there and then reparent to the camera? is there something else I need to do?

Have you moved the camera from its initial position?

By default, (if I recall correctly) the camera is located at (0, 0, 0), and faces down the y-axis. If your scene is centred on (0, 0, 0), and especially if your “floor” is at a height of 0, then the camera may be seeing the floor edge-on, and have the rest placed out of its view. (For example, if the table is centred, then the tabletop may be above the camera-frustum and the legs to either side of it.

In short, I suggest pulling the camera back a bit by setting its position, and perhaps shifting it along the z-axis.

Note, too, that the scale of your model may have an effect–if it’s very big or very small it might be harder to see.

That definitely helped at least see the viewport. You can see the images here:

It looks like the floor model just doesn’t exist. Tried 0.25 scale, and 25 scale, nothing appears. At least I can isolate the problem.

Based then on the code, exists when the Panda3D run is initialized. It’s not explicitly stated, but it’s a class variable initialized behind the scenes.

Thank you!

Hmm… Could the floor’s polygons perhaps be facing the wrong way, causing them to be backface-culled?

You could perhaps test this by moving the camera beneath the floor, and seeing whether it then becomes visible.

It’s my pleasure! :slight_smile: