Need help for importing glb file into panda3d


I’m quite new to Panda3D, so what I’m going to discuss will result quite trivial for most of you(I suppose).

What I’m trying to accomplish is to load an animated .glb model into my game. The problem is that, when I try to play the animation in a loop, it gets stuck on the first frame and when I try to analyze it using the getNumFrames() method it returns 2(the animation has 80 frames).
Here are the export settings:

Include → Limit to → Selected objects
Transform → +Y Up
Geometry → UVs, Normals, Vertex colors
Animation → Animation → Limit to playback range, Sampling rate=1, Always sample
animations, Group by NLA track
Animation → Shape keys → Shape key normals

Any idea on what I’m doing wrong? Thanks :slight_smile:

P.s: please, let me know if more details could help understanding the issue.

BTW, here is the model’s file(I thought it may prove useful):

Well, I suppose that it’s worth asking, just in case: what is the playback range when you export?

Hello, thanks for answering.

You mean the playback/rendering range set in the “Animation” tab in Blender? If so, it is 1-250.

1 Like

Hmm, fair. In that case, I’ll leave this question to those who know the format better!

You might want to give blend2bam a try since it automatically uses optimal settings for both the Blender glTF exporter and panda3d-gltf. I remember animations being a touch tricky to get the correct settings on, but I do not remember the details.

1 Like

Hello, thanks for answering. Actually, I also tried blend2bam but it didn’t solve the issue. I have solved it by switching to Blender 2.79 and using YABEE: now everything works fine :slight_smile: