NameError... again...

I wanna use panda but i stoped in some problems. Some of them were solved, but the nameerror still exist. :angry:

DirectStart: Starting the game.
Traceback (most recent call last):
File “”, line 1, in ?
File “/home/netto/Desktop/Panda3D/panda3d-”, line 3, in ?
File “/home/netto/Desktop/Panda3D/panda3d/built/direct/…/…/direct/src/showbase/”, line 6, in ?
from pandac.PandaModules import *
File “/home/netto/Desktop/Panda3D/panda3d/built/pandac/”, line 1, in ?
from libpandaexpressModules import *
File “/home/netto/Desktop/Panda3D/panda3d/built/pandac/”, line 20, in ?
Dtool_funcToMethod(readlines, Ramfile)
NameError: name ‘Ramfile’ is not defined

Someone could help me?? Before i throw my pc in a lake?? :smiley:

Did you build Panda from source, or did you download a prebuilt binary from this website? Something appears to have gone wrong with your build, or possibly you are loading the wrong version of Do you have multiple copies of Panda installed in different places?


First i installed from rpm file, but it don´t work, so i tried the source and it works until this error. Maybe i have different copies of panda, but i don´t know where they are. I´ll search for the most new version of libpandaexpress and try again.

Thanks so much!! If i could run the app i´ll be back :smiley:

Did you uninstall the rpm file after it didn’t work? If it’s still around, it may be competing with the version of Panda you’re trying to build from source. Make sure the rpm file is completely uninstalled (erased).


Could u help me? I am new in linux OS, so i don’t know how to uninstall a rpm file.
What can i do (and can’t do)?

try as root
rpm -e paketname
or if you use yum (fedora and suse might use yum)
yum remove paketname

you can probe for a paket with
rpm -q paketname
this tells you if the paket is installed or not. once you

for a full list of parameters just type yum or rpm.

you should make shure there are no dependencies or rpm will complain, yum offers to remove them but have a close look. not that it’s removing anything important.

form my experience it’s best to grep the latest panda release and compile it yourself.

Thanks!! Now it works well!! :laughing: