My Kingdom for an Egg

After I drag the Maya Panda tool into the Maya10 workspace and export there is nothing in the preview. The .mb file it created will not convert to .egg (or I can’t find it) I’ve set up the proper phong shade. I’ve tried to run the maya2egg10 the non-GUI way but my machine cannot open it. Someone help, what am I missing.

If you can’t run maya2egg10, then none of the GUI tools will work. So first we have to find out what’s wrong with the command-line tool.

What error message do you get when you run it?


Thanks for the reply. I cannot launch any of the maya2eggs, my computer can’t find the proper program. I know the manual says that before you can install the exporter you must run vcredist_x86-sp1.exe but I can’t find it on my system or in the panda bin. I’ve know I have this file somewhere on my machine because I tryed to download it online and was confirmed. Is there some scripting I must do that I’m unaware of?

What happens if you open a command shell and type the command:

maya2egg10 -h



NameError: name ‘maya2Egg10’ is not defined

I did’nt capitalize egg in the code

dont know much but for the vcredist - maybe you just got the wrong vcredist as there are several (at least 2 - the search is not so good, i think) possibilities for a SP 1

That sounds like that’s a Python error message. I want to you open a Windows Command shell, not a Python shell. On Windows XP, pick “Run” from the Start menu, and type “cmd” to open a command shell. On Windows Vista, type “cmd” in the “Start Search” box.


I didn’y know if it was suppose to run out of the bin or plugins or just plain C: directory but in every case it returns ‘maya2egg10’ is not recognized as an internal or external command, operable program or batch file.

Oh, on reflection, it doesn’t look like we ship a maya2egg10. There’s maya2egg2009. What version of Maya are you running?


The exe is maya2egg2010 (not maya2egg10) …did you try that as well?


EDIT: wait you’re right David it didn’t ship/get released in any case. So it wouldn’t be there. Sorry about that.

I did try that. That last bit of your message, are you saying it doesn’t exist. If so, when might it?

I’m running maya 2010, any idea if the old exporter works with it or when maya2egg2010 will be available

As for getting it into a “release” download. I can’t speak to that.

A few of us here at CMU are currently trying to fix a few bugs in the exporter at this very moment. The build we have isn’t guaranteed to be stable, and we haven’t been checking it into the official Panda code repository for that reason. However, if you’re really stuck I may be able to post the 2010 eggers we are currently testing out somewhere on the net. If you want them let me know, and i’ll post them. You’re using Panda 1.7 correct?


This is correct, I am using version 1.7.0. I would appreciate whatever you are testing. One more thing, going back to the previous issues, even though I do not need the older versions of maya2egg I tried run those anyway to see what happens and I have the same problem; cmd tells me it hasn’t been installed. As per previous posts, I am without the proper program to install these (or so it appears) from the plugins directory.

I think those issues may be coming from not having Panda in your system path. the directory C:<wherever you installed Panda>\bin needs to be in there in order to run the command line utils from any directory.

As for the egger, it’s going to take me a day I think, considering we’re in the middle of snowmagedon here in the Eastern US, and my builds are not with me at home at the moment. please feel free to PM me if I forget.

Ha, I’m right there with you in the blustery East, so I understand. Thanks

I just stumbled across this thread in my search for a Maya 2010 exporter. I assume the snow has thawed in PA since February… any luck on getting the maya2egg2010 package ready for prime time? I still don’t see it in any of the builds.