More deploy-ng issues

I am using panda3d version panda3d==1.10.0.dev1932+deployng.261. As of right now this is the most recent version on the deploy-ng branch.

Trying to run my game built with deploy-ng gives this error:

AttributeError: module '_frozen_importlib' has no attribute '_install_external_importers'
Fatal Python error: initexternalimport: external importer setup failed

Current thread 0x00007f49ee067b80 (most recent call first):
[1]    8934 abort (core dumped)  ./Underlord

I thought it might be something with my game so I tried running the asteroids demo as well, but it also coredumped:

[1]    10229 abort (core dumped)  ./asteroids

I also tried deleting everything in the build folder and rebuilding, with the same result.

Which Python version? Which platform and architecture?

Python 3.6.5, Ubuntu 18.04 x86_64

Just tried this with Python 3.7.0 and it works properly. It still happens if I build with Python 3.6.5 though.

Thanks for testing a different version of Python. I can confirm that Python 3.6 appears to be broken for deploy-ng, and I am digging into it.

Note that _install_external_importers is altogether absent from Python 3.6’s I am wondering if there is confusion between different Python versions going on here.

@rdb fixed an issue with the buildbot builds that was causing this. I can confirm that the recent Python 3.6 manylinux1 wheels are working again. The Windows and macOS wheels are still building.

@Air_Control, can you check to see if this is fixed for you as well?

Yes, it works for me now with both python3.6 and 3.7.