Mipmapping/Blender problem

Well, i was told that mipmapping is automatic although one can adjust mipmap settings by using Texture class methods. However it doesn’t work for me. What I have is a egg/bam model exported from Blender (2.49b). In Blender it looks OK, but if I import it to Panda3d (1.70), the texture gets kind of pixelated from the distance (or from the angle). Here’s the pic: yfrog.com/7hmipmapj
This definitely looks as if no mipmapping is applied
Maybe I miss something in the Blender’s material settings (Blender’s texturing system looks so messed up to me ;( )
Or maybe I should enable something at the Panda3D’s level?
In the egg file, there are the lines:

carpet.jpg {
saved-result { 1 }
envtype { MODULATE }
minfilter { LINEAR }
magfilter { LINEAR }
wrap { REPEAT }

The manual says “FTLinear is a good general-purpose choice, though it isn’t perfect”…
What are other options?

Try LINEAR_MIPMAP_LINEAR. If you enable mipmapping on the image in Blender, it should also export with mipmapping to Panda3D, if you have a recent Chicken version.

Thanks! It worked. Gotta fight with the Blender’s interface now…

I got it…
You should go to Material Buttons -> Map Input panel and select ‘UV’ (default is ‘Orco’) (only if the model has UV mapping I guess). Otherwise mipmap will be exported as LINEAR even if MipMap option is enabled (what is by default actually).