maya2egg7 Missing MFC80.dll?????

Hi, I’m trying to help one of my animators use the exporter. When we try to run maya2egg7.exe from his command line we get a mysterious error dialog popup that complains about a missing MFC80.dll. I only ran this command “C:\Panda3d-1.3.2\bin\maya2egg7.exe -h” to try and get at least the help page to display and it displays this message.

Maya 7 is installed in his machine (he uses it everyday). He also has Panda3d-1.3.2 installed. As far as I can tell he has a completely normal installation everything else seems to work except this.

I searched my computer and I do not have MFC80.dll either but maya2egg7 work fine for me. The only difference I can think of between my system and his system is that he downloaded/installed panda today but mine was installed when 1.3.2 was released.

Is it possible that someone re-compiled the panda3d-1.3.2 distribution recently and for some reason maya2egg7 was compiled using VC2005 which inadvertantly created a dependency to MFC8.dll? This seems remote to me, but I am at a loss otherwise.


I think you are inadvertently picking up the wrong version of OpenMaya.dll (for instance, from maya 8.0, hence the filename).

Try making sure that your PATH and/or your MAYA_LOCATION environment variables are correctly set to reference the Maya 7 DLL’s before the Maya 8 DLL’s.


Excellent Answer! I didn’t realize the artist had Maya 8.5 installed as well as Maya 7.0. I just switched their order in the PATH and everything works fine now.


where exactly does one make a change to the path / maya location env variables? I am having a similar problem…

Somewhere around version 1.4.0, I added some code to fix this problem once and for all. It should no longer be happening. Therefore, I suspect that your problem really isn’t the same problem. What error message are you getting, exactly, and under what circumstances?

I’m using the Maya Tool 3 which I believe is a modified version of the tool by ynjh_jo. The problem is, I don’t get an error. Instead, Maya claims the file was exported to .egg when in reality no .egg file is created and I’m left with a temp file of the original maya binary (cube_temp.mb).

I saw in another thread (couldn’t find it again when I searched) that ynjh_jo suggsted its a problem where a certain DLL file can’t be found and the path needs to be changed in the env variable. So I was just wondering where I can change that (and what DLL is it trying to find?).

I’m currently using Maya 8, but I use to use Maya 6, so I’m guessing its finding the wrong DLL.

…Or should I be using a different maya2egg converter? Thanks for your help :blush:

I’m not familiar with the maya tool. What does it do?

Its the 3rd version of the same tool (MayaPandaTool) thats in Panda’s plug-ins folder. Its a mel script that has a nice gui with options for converting maya binaries to .egg files.

I know that tool. At least in the original version, it works by running maya2egg. I think you should try running maya2egg by hand. If that works, then the problem is in the MEL script.

ok, I ran it in the command prompt and that worked. I probably should have tried that before posting. Sorry.

I’ll post again when I have done something interesting with the roaming ralph tutorial. :wink:

I guess I should clarify I ran maya2egg8 in the command prompt, not the MayaPandaTool3. I would still like to use the MayaPandaTool (or something similar) since it seems easier to use, what with all the options easily selectable from the gui…

I’m not saying you shouldn’t use the MEL script. I just wanted to rule out a particular category of errors. Now we just need to figure out what’s wrong with the MEL script. :wink:

Try to open Maya ScriptEditor before export, and see what possibly wrong, or post the result.